diff mbox

[OpenWrt-Devel,1/2] ncdu: update to 1.11

Message ID 20150502115048.4df01257@cel.celehner.com
State Not Applicable
Headers show

Commit Message

Charles Lehner May 2, 2015, 3:50 p.m. UTC
Add patch to get WEXITSTATUS and WIFEXITED defined.

This patch will not be needed in the next ncdu release
because it is already fixed upstream.

Signed-off-by: Charles Lehner <cel@celehner.com>
---
 utils/ncdu/Makefile                       |  4 ++--
 utils/ncdu/patches/010-add_sys_wait.patch | 10 ++++++++++
 2 files changed, 12 insertions(+), 2 deletions(-)
 create mode 100644 utils/ncdu/patches/010-add_sys_wait.patch

Comments

John Crispin May 22, 2015, 6:44 p.m. UTC | #1
Hi,

ncdu is part of the github feed. please file an issue there

	John

On 02/05/2015 17:50, Charles Lehner wrote:
> Add patch to get WEXITSTATUS and WIFEXITED defined.
> 
> This patch will not be needed in the next ncdu release
> because it is already fixed upstream.
> 
> Signed-off-by: Charles Lehner <cel@celehner.com>
> ---
>  utils/ncdu/Makefile                       |  4 ++--
>  utils/ncdu/patches/010-add_sys_wait.patch | 10 ++++++++++
>  2 files changed, 12 insertions(+), 2 deletions(-)
>  create mode 100644 utils/ncdu/patches/010-add_sys_wait.patch
> 
> diff --git a/utils/ncdu/Makefile b/utils/ncdu/Makefile
> index edd8527..bae46bd 100644
> --- a/utils/ncdu/Makefile
> +++ b/utils/ncdu/Makefile
> @@ -8,12 +8,12 @@
>  include $(TOPDIR)/rules.mk
>  
>  PKG_NAME:=ncdu
> -PKG_VERSION:=1.10
> +PKG_VERSION:=1.11
>  PKG_RELEASE=1
>  
>  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
>  PKG_SOURCE_URL:=http://dev.yorhel.nl/download
> -PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
> +PKG_MD5SUM:=9e44240a5356b029f05f0e70a63c4d12
>  
>  PKG_INSTALL:=1
>  
> diff --git a/utils/ncdu/patches/010-add_sys_wait.patch b/utils/ncdu/patches/010-add_sys_wait.patch
> new file mode 100644
> index 0000000..b6ffe44
> --- /dev/null
> +++ b/utils/ncdu/patches/010-add_sys_wait.patch
> @@ -0,0 +1,10 @@
> +--- ncdu-1.11/src/shell.c
> ++++ ncdu-1.11/src/shell.c
> +@@ -33,6 +33,7 @@
> + #include <stdlib.h>
> + #include <unistd.h>
> ++#include <sys/wait.h>
> + 
> + void shell_draw() {
> +   char *full_path;
> +   int res;
>
diff mbox

Patch

diff --git a/utils/ncdu/Makefile b/utils/ncdu/Makefile
index edd8527..bae46bd 100644
--- a/utils/ncdu/Makefile
+++ b/utils/ncdu/Makefile
@@ -8,12 +8,12 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncdu
-PKG_VERSION:=1.10
+PKG_VERSION:=1.11
 PKG_RELEASE=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dev.yorhel.nl/download
-PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
+PKG_MD5SUM:=9e44240a5356b029f05f0e70a63c4d12
 
 PKG_INSTALL:=1
 
diff --git a/utils/ncdu/patches/010-add_sys_wait.patch b/utils/ncdu/patches/010-add_sys_wait.patch
new file mode 100644
index 0000000..b6ffe44
--- /dev/null
+++ b/utils/ncdu/patches/010-add_sys_wait.patch
@@ -0,0 +1,10 @@ 
+--- ncdu-1.11/src/shell.c
++++ ncdu-1.11/src/shell.c
+@@ -33,6 +33,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <sys/wait.h>
+ 
+ void shell_draw() {
+   char *full_path;
+   int res;