diff mbox

[OpenWrt-Devel,2/2] toolchain/gcc/final: Add --disable-werror

Message ID 20150304185800.GA23189@ubuntu
State Changes Requested
Headers show

Commit Message

Jeff Waugh March 4, 2015, 6:58 p.m. UTC
Hi all,

This was the least dirty way I could find to stop the build blowing up
with a maybe-uninitialized error. The code in question hadn't changed
upstream, either... at least until it was removed.

Thanks,
Jeff


I'm not convinced this is the right thing to do, but it's required
for libgo to build from gcc 4.9. Thus, separate commit / patch.

Signed-off-by: Jeff Waugh <jdub@bethesignal.org>
---
 toolchain/gcc/final/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3fb5ccf..955c92b 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -8,7 +8,8 @@  GCC_CONFIGURE += \
 	--enable-languages=$(TARGET_LANGUAGES) \
 	--enable-shared \
 	--enable-threads \
-	--with-slibdir=$(TOOLCHAIN_DIR)/lib
+	--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+	--disable-werror
 
 ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
   GCC_CONFIGURE += \