diff mbox

[OpenWrt-Devel] oxnas: copy ubinized images to binary folder

Message ID 20150206140118.GA25634@makrotopia.org
State Accepted
Delegated to: John Crispin
Headers show

Commit Message

Daniel Golle Feb. 6, 2015, 2:01 p.m. UTC
Since r43778 ubinized images are stored inside KDIR. This makes sense
when using an uninized image to generate a factory image.
On oxnas ubinized images were used for sysupgrade before proper NAND
support was implemented in OpenWrt.
For users still on old builds before sysupgrade.tar was introduced,
ubinized image is thus the only option to conveniantly upgrade to a
more recent build.
Copy ubinized image also to BIN_DIR, so it will be easier for users
to find them.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 target/linux/oxnas/image/Makefile | 2 ++
 1 file changed, 2 insertions(+)
diff mbox

Patch

diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index a3dae16..b09c67e 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -89,6 +89,7 @@  endef
 define Image/Build/squashfs
 	$(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),$(1),$(KDIR)/fit-$(call sanitize_profile_name).itb)
 	$(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,$(1),$($(PROFILE)_UBI_OPTS))
+	cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-squashfs-ubinized.bin $(BIN_DIR)
 endef
 
 define Image/mkfs/targz
@@ -101,6 +102,7 @@  define Image/Build/ubifs
  ifneq ($($(PROFILE)_UBIFS_OPTS),)
 	$(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),ubifs,$(KDIR)/fit-$(call sanitize_profile_name).itb)
 	$(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,ubifs,$($(PROFILE)_UBI_OPTS))
+	cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-ubifs-ubinized.bin $(BIN_DIR)
  endif
 
 endef