diff mbox

[OpenWrt-Devel,1/2] opkg: work around unconditional libopenssl build dependency

Message ID 19282ca72228aac85fcb9adff5332dee773b27cd.1440751910.git.mschiffer@universe-factory.net
State Accepted
Headers show

Commit Message

Matthias Schiffer Aug. 28, 2015, 8:57 a.m. UTC
As the OpenWrt build system only resolves build dependencies per directory,
all opkg variants were causing libopenssl to be downloaded and built,
not only opkg-smime. Fix this by applying the same workaround as in
ustream-ssl.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
---
 package/system/opkg/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 32bcf2b..4da4d46 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -72,7 +72,7 @@  endef
 define Package/opkg-smime
   $(call Package/opkg/Default)
   TITLE+= (with S/MIME signature support)
-  DEPENDS+=+libopenssl
+  DEPENDS+=+PACKAGE_opkg-smime:libopenssl
   VARIANT:=smime
 endef