@@ -467,6 +467,12 @@ zbtlink,zbt-we1226)
ucidef_set_led_switch "lan2" "LAN2" "$boardname:green:lan2" "switch0" "0x02"
ucidef_set_led_switch "wan" "WAN" "$boardname:green:wan" "switch0" "0x10"
;;
+zhuotk,js76x8-16m|\
+zhuotk,js76x8-32m|\
+zhuotk,js76x8-8m)
+ ucidef_set_led_timer "system" "system" "js76x8:green:system" "1000" "1000"
+ set_wifi_led "js76x8:green:wifi"
+ ;;
zorlik,zl5900v2)
ucidef_set_led_netdev "lan" "lan" "$boardname:green:lan" eth0
;;
@@ -102,6 +102,9 @@ ramips_setup_interfaces()
zbtlink,zbt-wg3526-16m|\
zbtlink,zbt-wg3526-32m|\
zbtlink,zbt-wr8305rt|\
+ zhuotk,js76x8-16m|\
+ zhuotk,js76x8-32m|\
+ zhuotk,js76x8-8m|\
zyxel,keenetic|\
zyxel,keenetic-omni)
ucidef_add_switch "switch0" \
@@ -543,7 +546,10 @@ ramips_setup_macs()
hilink,hlk-rm04|\
nexaira,bc2|\
petatel,psr-680w|\
- skyline,sl-r7205)
+ skyline,sl-r7205|\
+ zhuotk,js76x8-16m|\
+ zhuotk,js76x8-32m|\
+ zhuotk,js76x8-8m)
lan_mac=$(macaddr_setbit_la "$(cat /sys/class/net/eth0/address)")
wan_mac=$(macaddr_add "$lan_mac" 1)
;;
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js76x8-16m", "zhuotk,js76x8", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS76x8 (16M)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js76x8-32m", "zhuotk,js76x8", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS76x8 (32M)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ flash0@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js76x8-8m", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS76x8 (8M)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
new file mode 100644
@@ -0,0 +1,105 @@
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "zhuotk,js76x8", "mediatek,mt7628an-soc";
+
+ aliases {
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "js76x8:green:system";
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi {
+ label = "js76x8:green:wifi";
+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_HIGH>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "gpio","p3led_an","p4led_an",
+ "pwm0","pwm1","refclk","wdt","wled_an";
+ ralink,function = "gpio";
+ };
+
+ p0led {
+ ralink,group = "p0led_an";
+ ralink,function = "p0led_an";
+ };
+
+ p1led {
+ ralink,group = "p1led_an";
+ ralink,function = "p1led_an";
+ };
+
+ p2led {
+ ralink,group = "p2led_an";
+ ralink,function = "p2led_an";
+ };
+
+ pwm_2_3 {
+ ralink,group = "uart2";
+ ralink,function = "pwm";
+ };
+ };
+
+ uart2 {
+ uart2 {
+ ralink,group = "spis";
+ ralink,function = "pwm_uart2";
+ };
+ };
+};
+
+&i2c {
+ status = "okay";
+};
+
+&uart1 {
+ status = "okay";
+};
+
+&uart2 {
+ status = "okay";
+};
+
+ðernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&sdhci {
+ status = "okay";
+ mediatek,cd-low;
+};
+
+&wmac {
+ status = "okay";
+};
@@ -583,6 +583,36 @@ define Device/zbtlink_zbt-we1226
endef
TARGET_DEVICES += zbtlink_zbt-we1226
+define Device/zhuotk_js76x8-16m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS76x8
+ DEVICE_VARIANT := 16M
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js76x8-16m
+
+define Device/zhuotk_js76x8-32m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS76x8
+ DEVICE_VARIANT := 32M
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js76x8-32m
+
+define Device/zhuotk_js76x8-8m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS76x8
+ DEVICE_VARIANT := 8M
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js76x8-8m
+
define Device/zyxel_keenetic-extra-ii
MTK_SOC := mt7628an
IMAGE_SIZE := 14912k
This commit adds support for the ZhuoTK JS76x8 series development boards. These devices has the following specifications: - SOC: MT7628AN/NN, MT7688AN, MT7628DAN - RAM of MT7628AN/NN and MT7688AN: 64/128/256 MB (DDR2) - RAM of MT7628DAN: 64 MB (DDR2) - FLASH:8/16/32 MB (SPI NOR) - Ethernet:3x 10/100 Mbps ethernet ports (MT76x8 built-in switch) - WIFI:1x 2T2R 2.4 GHz Wi-Fi - LEDs:1x system status green LED, 1x wifi green LED, 3x ethernet green LED - Buttons:1x reset button, 2x user defined button - 1x microSD slot - 4x USB 2.0 port - 1x mini-usb debug UART - 1x DC jack for main power (DC 5V) - 1x TTL/RS232 UART - 1x TTL/RS485 UART - 13x GPIO header - 1x audio codec(wm8960) Installation via OpenWrt: The original firmware is OpenWrt, so both LuCI or sysupgrade can be used. Installation via U-boot web: 1. Power on board with reset button pressed, release it after wifi led start blinking. 2. Setup static IP 192.168.1.123/4 on your PC. 3. Go to 192.168.1.8 in browser and upload "sysupgrade" image. Installation via U-boot tftp: 1. Connect to serial console at the mini usb, which has been connected to UART0 on board (115200 8N1) 2. Setup static IP 192.168.1.123/4 on your PC. 3. Place openwrt-firmware.bin on your PC tftp server (192.168.1.123). 3. Connect one of LAN ports on board to your PC. 4. Start terminal software (e.g. screen /dev/ttyUSB0 115200) on PC. 5. Apply power to board. 6. Interrupt U-boot with keypress of "2". 7. At u-boot prompts: Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N) Y Input device IP (192.168.1.8) ==:192.168.1.8 Input server IP (192.168.1.123) ==:192.168.1.123 Input Linux Kernel filename (root_uImage) ==:openwrt-firmware.bin 8. board will download file from tftp server, write it to flash and reboot. Other notes: Vist www.zhuotk.com for further information. Signed-off-by: Robinson Wu <wurobinson@qq.com> --- target/linux/ramips/base-files/etc/board.d/01_leds | 6 ++ .../linux/ramips/base-files/etc/board.d/02_network | 8 +- .../ramips/dts/mt7628an_zhuotk_js76x8-16m.dts | 60 ++++++++++++ .../ramips/dts/mt7628an_zhuotk_js76x8-32m.dts | 60 ++++++++++++ .../linux/ramips/dts/mt7628an_zhuotk_js76x8-8m.dts | 60 ++++++++++++ .../linux/ramips/dts/mt7628an_zhuotk_js76x8.dtsi | 105 +++++++++++++++++++++ target/linux/ramips/image/mt76x8.mk | 30 ++++++ 7 files changed, 328 insertions(+), 1 deletion(-) create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js76x8-16m.dts create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js76x8-32m.dts create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js76x8-8m.dts create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js76x8.dtsi