@@ -460,7 +460,10 @@ zbtlink,zbt-we1226)
;;
zhuotk,js7628-8m|\
zhuotk,js7628-16m|\
-zhuotk,js7628-32m)
+zhuotk,js7628-32m|\
+zhuotk,js7688-8m|\
+zhuotk,js7688-16m|\
+zhuotk,js7688-32m)
ucidef_set_led_timer "system" "system" "js76x8:green:system" "1000" "1000"
set_wifi_led "js76x8:green:wifi"
;;
@@ -106,6 +106,9 @@ ramips_setup_interfaces()
zhuotk,js7628-8m|\
zhuotk,js7628-16m|\
zhuotk,js7628-32m|\
+ zhuotk,js7688-8m|\
+ zhuotk,js7688-16m|\
+ zhuotk,js7688-32m|\
zyxel,keenetic|\
zyxel,keenetic-omni)
ucidef_add_switch "switch0" \
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js7688-16m", "zhuotk,js76x8", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS7688 (16M flash)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ m25p80@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js7688-32m", "zhuotk,js76x8", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS7688 (32M flash)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ m25p80@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
new file mode 100644
@@ -0,0 +1,60 @@
+/dts-v1/;
+
+#include "mt7628an_zhuotk_js76x8.dtsi"
+
+/ {
+ compatible = "zhuotk,js7688-8m", "zhuotk,js76x8", "mediatek,mt7628an-soc";
+ model = "ZhuoTK JS7688 (8M flash)";
+};
+
+&spi0 {
+ status = "okay";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+ m25p80@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+
+ spidev@1 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "linux,spidev";
+ reg = <1>;
+ spi-max-frequency = <40000000>;
+ };
+};
@@ -583,6 +583,36 @@ define Device/zhuotk_js7628-32m
endef
TARGET_DEVICES += zhuotk_js7628-32m
+define Device/zhuotk_js7688-8m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS7688
+ DEVICE_VARIANT := 8M flash
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js7688-8m
+
+define Device/zhuotk_js7688-16m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS7688
+ DEVICE_VARIANT := 16M flash
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js7688-16m
+
+define Device/zhuotk_js7688-32m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := ZhuoTK
+ DEVICE_MODEL := JS7688
+ DEVICE_VARIANT := 32M flash
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zhuotk_js7688-32m
+
define Device/zyxel_keenetic-extra-ii
MTK_SOC := mt7628an
IMAGE_SIZE := 14912k
This commit adds support for the ZhuoTK JS7688 development board, The device has the following specifications: - SOC:MT7688AN - RAM:64/128/256 MB (DDR2) - FLASH:8/16/32 MB (SPI NOR) - Ethernet:3x 10/100 Mbps ethernet ports (MT7688AN built-in switch) - WIFI:1x 2T2R 2.4 GHz Wi-Fi - LEDs:1x system status green LED, 1x wifi green LED, 3x ethernet green LED - Buttons:1x reset button, 2x user defined button - 1x microSD slot - 4x USB 2.0 port - 1x mini-usb debug UART - 1x DC jack for main power (DC 5V) - 1x TTL/RS232 UART - 1x TTL/RS485 UART - 13x GPIO header - 1x audio codec(wm8960) Installation via OpenWrt: The original firmware is OpenWrt, so both LuCI or sysupgrade can be used. Installation via U-boot web: 1. Power on board with reset button pressed, release it after wifi led start blinking. 2. Setup static IP 192.168.1.123/4 on your PC. 3. Go to 192.168.1.8 in browser and upload "sysupgrade" image. Installation via U-boot tftp: 1. Connect to serial console at the mini usb, which has been connected to UART0 on board (115200 8N1) 2. Setup static IP 192.168.1.123/4 on your PC. 3. Place openwrt-firmware.bin on your PC tftp server (192.168.1.123). 3. Connect one of LAN ports on board to your PC. 4. Start terminal software (e.g. screen /dev/ttyUSB0 115200) on PC. 5. Apply power to board. 6. Interrupt U-boot with keypress of "2". 7. At u-boot prompts: Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N) Y Input device IP (192.168.1.8) ==:192.168.1.8 Input server IP (192.168.1.123) ==:192.168.1.123 Input Linux Kernel filename (root_uImage) ==:openwrt-firmware.bin 8. board will download file from tftp server, write it to flash and reboot. Other notes: 1. This board is available with three types of RAM with flash configuration. Chose one of the right "Target Profile" in "make menuconfig" as listed below: "ZhuoTK JS7688 8M flash" "ZhuoTK JS7688 16M flash" "ZhuoTK JS7688 32M flash" to fit the board you have. Vist www.zhuotk.com for further information. Signed-off-by: Robinson Wu <wurobinson@qq.com> --- target/linux/ramips/base-files/etc/board.d/01_leds | 5 +- .../linux/ramips/base-files/etc/board.d/02_network | 3 ++ .../ramips/dts/mt7628an_zhuotk_js7688-16m.dts | 60 ++++++++++++++++++++++ .../ramips/dts/mt7628an_zhuotk_js7688-32m.dts | 60 ++++++++++++++++++++++ .../linux/ramips/dts/mt7628an_zhuotk_js7688-8m.dts | 60 ++++++++++++++++++++++ target/linux/ramips/image/mt76x8.mk | 30 +++++++++++ 6 files changed, 217 insertions(+), 1 deletion(-) create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js7688-16m.dts create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js7688-32m.dts create mode 100644 target/linux/ramips/dts/mt7628an_zhuotk_js7688-8m.dts