diff mbox series

[OpenWrt-Devel,v2] lantiq: image: build initramfs only for FRITZ7362SL

Message ID 1557137638-1558-1-git-send-email-ynezz@true.cz
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel,v2] lantiq: image: build initramfs only for FRITZ7362SL | expand

Commit Message

Petr Štetiar May 6, 2019, 10:13 a.m. UTC
Commit "lantiq/xrx200: enable initramfs images" enabled creation of
initramfs images for all devices in lantiq's xrx200 subtarget, just
because FRITZ7362SL needs initramfs during OpenWrt instalation.

Then David Bauer informed me, that FRITZ!Box 7412 also needs an initramfs
for initial installation [1], so I've added this device into this patch as
well.

So this commit changes lantiq to selective-ramdisk feature and adds
NEEDS_INITRAMFS=1 to FRITZ7362SL and FRITZ!Box 7412 devices only.

Cc: David Bauer <mail@david-bauer.net>
Cc: Stijn Segers <foss@volatilesystems.org>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---

 Changes since v1:

  * added FRITZ!Box 7412 device

 target/linux/lantiq/image/Makefile   | 2 ++
 target/linux/lantiq/xrx200/target.mk | 2 +-
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Stijn Segers May 8, 2019, 6:38 p.m. UTC | #1
Op maandag 6 mei 2019 om 12:13 schreef Petr Štetiar <ynezz@true.cz>:
> Commit "lantiq/xrx200: enable initramfs images" enabled creation of
> initramfs images for all devices in lantiq's xrx200 subtarget, just
> because FRITZ7362SL needs initramfs during OpenWrt instalation.
> 
> Then David Bauer informed me, that FRITZ!Box 7412 also needs an 
> initramfs
> for initial installation [1], so I've added this device into this 
> patch as
> well.
> 
> So this commit changes lantiq to selective-ramdisk feature and adds
> NEEDS_INITRAMFS=1 to FRITZ7362SL and FRITZ!Box 7412 devices only.

Hi Petr,

I think this is a nice solution to what up till now was a probably 
overly broad approach. I'm probably not familiar enough
with the whole buildroot, but would the other targets with the ramdisk 
feature not need similar scrutiny?

A quick grep from master:

$ git grep FEATURES target/linux/|grep ramdisk
target/linux/apm821xx/nand/target.mk:FEATURES += nand pcie ramdisk 
squashfs usb
target/linux/apm821xx/sata/target.mk:FEATURES += ext4 usb ramdisk 
squashfs rootfs-part boot-part
target/linux/ar71xx/mikrotik/target.mk:FEATURES += squashfs ramdisk 
minor nand
target/linux/arc770/generic/target.mk:FEATURES += ramdisk usb ext4
target/linux/archs38/generic/target.mk:FEATURES += ext4 usb ramdisk
target/linux/armvirt/Makefile:FEATURES+=cpiogz ext4 ramdisk squashfs 
targz
target/linux/ath79/Makefile:FEATURES:=ramdisk
target/linux/ipq40xx/Makefile:FEATURES:=squashfs fpu ramdisk nand
target/linux/ipq806x/Makefile:FEATURES:=squashfs nand fpu ramdisk
target/linux/kirkwood/Makefile:FEATURES:=usb nand squashfs ramdisk
target/linux/lantiq/xrx200/target.mk:FEATURES:=squashfs atm nand ramdisk
target/linux/lantiq/xway/target.mk:FEATURES:=squashfs atm nand ramdisk
target/linux/lantiq/xway_legacy/target.mk:FEATURES:=squashfs atm 
ramdisk small_flash
target/linux/malta/Makefile:FEATURES:=ramdisk
target/linux/mediatek/Makefile:FEATURES:=squashfs nand ramdisk fpu
target/linux/mpc85xx/Makefile:FEATURES:=squashfs ramdisk
target/linux/mvebu/Makefile:FEATURES:=fpu usb pci pcie gpio nand 
squashfs ramdisk boot-part rootfs-part
target/linux/octeon/Makefile:FEATURES:=squashfs ramdisk pci usb
target/linux/oxnas/Makefile:FEATURES:=gpio ramdisk rtc squashfs
target/linux/ramips/mt7621/target.mk:FEATURES+=nand ramdisk rtc usb 
minor
target/linux/ramips/rt305x/target.mk:FEATURES+=usb ramdisk small_flash

Cheers

Stijn

> 
> Cc: David Bauer <mail@david-bauer.net>
> Cc: Stijn Segers <foss@volatilesystems.org>
> Signed-off-by: Petr Štetiar <ynezz@true.cz>
> ---
> 
>  Changes since v1:
> 
>   * added FRITZ!Box 7412 device
> 
>  target/linux/lantiq/image/Makefile   | 2 ++
>  target/linux/lantiq/xrx200/target.mk | 2 +-
>  2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/lantiq/image/Makefile 
> b/target/linux/lantiq/image/Makefile
> index fca3fce..994dee4 100644
> --- a/target/linux/lantiq/image/Makefile
> +++ b/target/linux/lantiq/image/Makefile
> @@ -674,6 +674,7 @@ define Device/avm_fritz7412
>    IMAGE_SIZE := 49152k
>    DEVICE_TITLE := AVM FRITZ!Box 7412
>    DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini 
> kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
> +  NEEDS_INITRAMFS := 1
>  endef
>  TARGET_DEVICES += avm_fritz7412
> 
> @@ -685,6 +686,7 @@ define Device/avm_fritz7362sl
>    DEVICE_DTS := FRITZ7362SL
>    DEVICE_TITLE := AVM FRITZ!Box 7362 SL
>    DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic 
> kmod-usb-dwc2 fritz-tffs
> +  NEEDS_INITRAMFS := 1
>  endef
>  TARGET_DEVICES += avm_fritz7362sl
> 
> diff --git a/target/linux/lantiq/xrx200/target.mk 
> b/target/linux/lantiq/xrx200/target.mk
> index 4d92b25..8740794 100644
> --- a/target/linux/lantiq/xrx200/target.mk
> +++ b/target/linux/lantiq/xrx200/target.mk
> @@ -1,7 +1,7 @@
>  ARCH:=mips
>  SUBTARGET:=xrx200
>  BOARDNAME:=XRX200
> -FEATURES:=squashfs atm nand ramdisk
> +FEATURES:=squashfs atm nand selective-ramdisk
>  CPU_TYPE:=24kc
> 
>  DEFAULT_PACKAGES+=kmod-leds-gpio \
> --
> 1.9.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Petr Štetiar May 9, 2019, 8:37 a.m. UTC | #2
Stijn Segers <foss@volatilesystems.org> [2019-05-08 20:38:09]:

Hi,

> Op maandag 6 mei 2019 om 12:13 schreef Petr Štetiar <ynezz@true.cz>:
> > Commit "lantiq/xrx200: enable initramfs images" enabled creation of
> > initramfs images for all devices in lantiq's xrx200 subtarget, just
> > because FRITZ7362SL needs initramfs during OpenWrt instalation.
> > 
> > Then David Bauer informed me, that FRITZ!Box 7412 also needs an
> > initramfs
> > for initial installation [1], so I've added this device into this patch
> > as
> > well.
> > 
> > So this commit changes lantiq to selective-ramdisk feature and adds
> > NEEDS_INITRAMFS=1 to FRITZ7362SL and FRITZ!Box 7412 devices only.
> 
> I think this is a nice solution to what up till now was a probably overly
> broad approach. I'm probably not familiar enough
> with the whole buildroot, but would the other targets with the ramdisk
> feature not need similar scrutiny?

very likely yes, but it would be pretty tedious work to find devices which
would need NEEDS_INITRAMFS=1 and switch those targets to selective-ramdisk
instead.

> A quick grep from master:
> 
> $ git grep FEATURES target/linux/|grep ramdisk
> target/linux/apm821xx/nand/target.mk:FEATURES += nand pcie ramdisk squashfs usb
> target/linux/apm821xx/sata/target.mk:FEATURES += ext4 usb ramdisk squashfs rootfs-part boot-part
> target/linux/ar71xx/mikrotik/target.mk:FEATURES += squashfs ramdisk minor nand
> target/linux/arc770/generic/target.mk:FEATURES += ramdisk usb ext4
> target/linux/archs38/generic/target.mk:FEATURES += ext4 usb ramdisk
> target/linux/armvirt/Makefile:FEATURES+=cpiogz ext4 ramdisk squashfs targz
> target/linux/ath79/Makefile:FEATURES:=ramdisk
> target/linux/ipq40xx/Makefile:FEATURES:=squashfs fpu ramdisk nand
> target/linux/ipq806x/Makefile:FEATURES:=squashfs nand fpu ramdisk
> target/linux/kirkwood/Makefile:FEATURES:=usb nand squashfs ramdisk
> target/linux/lantiq/xrx200/target.mk:FEATURES:=squashfs atm nand ramdisk
> target/linux/lantiq/xway/target.mk:FEATURES:=squashfs atm nand ramdisk
> target/linux/lantiq/xway_legacy/target.mk:FEATURES:=squashfs atm ramdisk small_flash
> target/linux/malta/Makefile:FEATURES:=ramdisk
> target/linux/mediatek/Makefile:FEATURES:=squashfs nand ramdisk fpu
> target/linux/mpc85xx/Makefile:FEATURES:=squashfs ramdisk
> target/linux/mvebu/Makefile:FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part
> target/linux/octeon/Makefile:FEATURES:=squashfs ramdisk pci usb
> target/linux/oxnas/Makefile:FEATURES:=gpio ramdisk rtc squashfs
> target/linux/ramips/mt7621/target.mk:FEATURES+=nand ramdisk rtc usb minor
> target/linux/ramips/rt305x/target.mk:FEATURES+=usb ramdisk small_flash

which makes me wonder if this selective-ramdisk patch is really worth the
effort, maybe we should just really enable ramdisk feature when the initramfs
is needed for any device under that target and just live with that fact.

-- ynezz
diff mbox series

Patch

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index fca3fce..994dee4 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -674,6 +674,7 @@  define Device/avm_fritz7412
   IMAGE_SIZE := 49152k
   DEVICE_TITLE := AVM FRITZ!Box 7412
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
+  NEEDS_INITRAMFS := 1
 endef
 TARGET_DEVICES += avm_fritz7412
 
@@ -685,6 +686,7 @@  define Device/avm_fritz7362sl
   DEVICE_DTS := FRITZ7362SL
   DEVICE_TITLE := AVM FRITZ!Box 7362 SL
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-usb-dwc2 fritz-tffs
+  NEEDS_INITRAMFS := 1
 endef
 TARGET_DEVICES += avm_fritz7362sl
 
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
index 4d92b25..8740794 100644
--- a/target/linux/lantiq/xrx200/target.mk
+++ b/target/linux/lantiq/xrx200/target.mk
@@ -1,7 +1,7 @@ 
 ARCH:=mips
 SUBTARGET:=xrx200
 BOARDNAME:=XRX200
-FEATURES:=squashfs atm nand ramdisk
+FEATURES:=squashfs atm nand selective-ramdisk
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio \