diff mbox series

[OpenWrt-Devel] build: Allow simple build system customization with local.mk

Message ID 1546822621-991-1-git-send-email-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel] build: Allow simple build system customization with local.mk | expand

Commit Message

Petr Štetiar Jan. 7, 2019, 12:57 a.m. UTC
I tend to automate most of the boring and repetitive tasks like firmware
flashing, build config reconfiguration etc., so I always end up adding
`include local.mk` as a last line in my Makefile, where local.mk is
usually symlink to some other place, just to not accidentally delete it
during `git clean`.

Carrying this single uncommited modification along in the development
process is quite PITA, because it's causing problems during Git
workflow, while rebasing etc.

I hope, that I'm not alone using similar workflow, so I believe, that
this modification might be useful for others as well.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 Makefile | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index 5301883..1ccfd61 100644
--- a/Makefile
+++ b/Makefile
@@ -103,3 +103,5 @@  world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif
+
+-include local.mk