diff mbox

[OpenWrt-Devel,2/2] linux/net: Add dependency for crypto echainiv module on 4.4

Message ID 1454192135-11543-2-git-send-email-avalentin@marcant.net
State Changes Requested
Headers show

Commit Message

André Valentin Jan. 30, 2016, 10:15 p.m. UTC
This dependency is needed to be able to create ipsec xfrm states.

Signed-off-by: André Valentin <avalentin@marcant.net>
---
 package/kernel/linux/modules/netsupport.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

John Crispin Feb. 12, 2016, 8:27 a.m. UTC | #1
Hi,



On 30/01/2016 23:15, André Valentin wrote:
> This dependency is needed to be able to create ipsec xfrm states.
> 
> Signed-off-by: André Valentin <avalentin@marcant.net>
> ---
>  package/kernel/linux/modules/netsupport.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
> index 0215722..39491aa 100644
> --- a/package/kernel/linux/modules/netsupport.mk
> +++ b/package/kernel/linux/modules/netsupport.mk
> @@ -286,7 +286,7 @@ IPSEC-m:= \
>  define KernelPackage/ipsec
>    SUBMENU:=$(NETWORK_SUPPORT_MENU)
>    TITLE:=IPsec related modules (IPv4 and IPv6)
> -  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
> +  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc +LINUX_4_4:kmod-crypto-echainiv

Hi,

should this not use the -ge syntax ? right now this wont work on v4.5

	John

>    KCONFIG:= \
>  	CONFIG_NET_KEY \
>  	CONFIG_XFRM_USER \
>
André Valentin Feb. 15, 2016, 7:52 p.m. UTC | #2
Hi!
Am 12.02.2016 um 09:27 schrieb John Crispin:
> Hi,
> 
> 
> 
> On 30/01/2016 23:15, André Valentin wrote:
>> This dependency is needed to be able to create ipsec xfrm states.
>>
>> Signed-off-by: André Valentin <avalentin@marcant.net>
>> ---
>>  package/kernel/linux/modules/netsupport.mk | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
>> index 0215722..39491aa 100644
>> --- a/package/kernel/linux/modules/netsupport.mk
>> +++ b/package/kernel/linux/modules/netsupport.mk
>> @@ -286,7 +286,7 @@ IPSEC-m:= \
>>  define KernelPackage/ipsec
>>    SUBMENU:=$(NETWORK_SUPPORT_MENU)
>>    TITLE:=IPsec related modules (IPv4 and IPv6)
>> -  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
>> +  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc +LINUX_4_4:kmod-crypto-echainiv
> 
> Hi,
> 
> should this not use the -ge syntax ? right now this wont work on v4.5
Do you have an example of this? I grepped package/linux for DEPENDS, but could not find a hint.

Kind regards,

André
diff mbox

Patch

diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 0215722..39491aa 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -286,7 +286,7 @@  IPSEC-m:= \
 define KernelPackage/ipsec
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPsec related modules (IPv4 and IPv6)
-  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
+  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc +LINUX_4_4:kmod-crypto-echainiv
   KCONFIG:= \
 	CONFIG_NET_KEY \
 	CONFIG_XFRM_USER \