diff mbox

[OpenWrt-Devel,2/2] kernel: other: add PWM controller support

Message ID 1453847849-31447-3-git-send-email-psidhu@gateworks.com
State Not Applicable
Headers show

Commit Message

Pushpal Sidhu Jan. 26, 2016, 10:37 p.m. UTC
This adds basic PWM controller support and support for i.MX

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
---
 package/kernel/linux/modules/other.mk | 36 +++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Pushpal Sidhu Jan. 27, 2016, 6 p.m. UTC | #1
I just realized that this isn't necessary for imx anymore as it's
static in the 4.4 kernel. I'll mark it as 'not applicable'.

- Pushpal

On Tue, Jan 26, 2016 at 2:37 PM, Pushpal Sidhu <psidhu@gateworks.com> wrote:
> This adds basic PWM controller support and support for i.MX
>
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
> ---
>  package/kernel/linux/modules/other.mk | 36 +++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 3039180..8edf8a6 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -371,6 +371,42 @@ endef
>  $(eval $(call KernelPackage,mmc))
>
>
> +define KernelPackage/pwm
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Pulse-Width Modulation support
> +  KCONFIG:= \
> +       CONFIG_PWM=y \
> +       CONFIG_REGULATOR_PWM=n \
> +       CONFIG_PWM_FSL_FTM=n
> +endef
> +
> +define KernelPackage/pwm/description
> + Pulse Width Modulation subsystem.
> +endef
> +
> +$(eval $(call KernelPackage,pwm))
> +
> +define AddDepends/pwm
> +  SUBMENU:=$(OTHER_MENU)
> +  DEPENDS+=kmod-pwm $(1)
> +endef
> +
> +define KernelPackage/pwm-imx
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=IMX Pulse-Width Modulation support
> +  KCONFIG:=CONFIG_PWM_IMX
> +  FILES:= $(LINUX_DIR)/drivers/pwm/pwm-imx.ko
> +  DEPENDS:=@TARGET_imx6
> +  AUTOLOAD:=$(call AutoProbe,pwm-imx)
> +  $(call AddDepends/pwm)
> +endef
> +
> +define KernelPackage/pwm-imx/description
> + Freescale IMX Pulse Width Modulation support.
> +endef
> +
> +$(eval $(call KernelPackage,pwm-imx))
> +
>  define KernelPackage/sdhci
>    SUBMENU:=$(OTHER_MENU)
>    TITLE:=Secure Digital Host Controller Interface support
> --
> 2.7.0
>
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3039180..8edf8a6 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -371,6 +371,42 @@  endef
 $(eval $(call KernelPackage,mmc))
 
 
+define KernelPackage/pwm
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Pulse-Width Modulation support
+  KCONFIG:= \
+	CONFIG_PWM=y \
+	CONFIG_REGULATOR_PWM=n \
+	CONFIG_PWM_FSL_FTM=n
+endef
+
+define KernelPackage/pwm/description
+ Pulse Width Modulation subsystem.
+endef
+
+$(eval $(call KernelPackage,pwm))
+
+define AddDepends/pwm
+  SUBMENU:=$(OTHER_MENU)
+  DEPENDS+=kmod-pwm $(1)
+endef
+
+define KernelPackage/pwm-imx
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=IMX Pulse-Width Modulation support
+  KCONFIG:=CONFIG_PWM_IMX
+  FILES:= $(LINUX_DIR)/drivers/pwm/pwm-imx.ko
+  DEPENDS:=@TARGET_imx6
+  AUTOLOAD:=$(call AutoProbe,pwm-imx)
+  $(call AddDepends/pwm)
+endef
+
+define KernelPackage/pwm-imx/description
+ Freescale IMX Pulse Width Modulation support.
+endef
+
+$(eval $(call KernelPackage,pwm-imx))
+
 define KernelPackage/sdhci
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Secure Digital Host Controller Interface support