diff mbox

[OpenWrt-Devel,1/2] kernel: add mma8451 module

Message ID 1453847849-31447-2-git-send-email-psidhu@gateworks.com
State Not Applicable
Headers show

Commit Message

Pushpal Sidhu Jan. 26, 2016, 10:37 p.m. UTC
Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
---
 package/kernel/linux/modules/input.mk | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 3f50a9f..b50106b 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -224,3 +224,20 @@  define KernelPackage/input-uinput/description
 endef
 
 $(eval $(call KernelPackage,input-uinput))
+
+
+define KernelPackage/input-mma8451
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=MMA8451 input device driver
+  DEPENDS:=+kmod-i2c-core +kmod-input-polldev
+  KCONFIG:=CONFIG_INPUT_MMA8451
+  FILES:=$(LINUX_DIR)/drivers/input/misc/mma8451.ko
+  AUTOLOAD:=$(call AutoProbe,mma8451)
+  $(call AddDepends/input)
+endef
+
+define KernelPackage/input-mma8451/description
+ MMA8451 device driver
+endef
+
+$(eval $(call KernelPackage,input-mma8451))