diff mbox

[OpenWrt-Devel,07/13] include/kernel: set build timestamp to SOURCE_DATE_EPOCH if available

Message ID 1453754975-18721-8-git-send-email-lynxis@fe80.eu
State Changes Requested
Headers show

Commit Message

Alexander 'lynxis' Couzens Jan. 25, 2016, 8:49 p.m. UTC
There is no additional information in the build timestamp.
As long we have no information on the kernel timestamp,
use as constant base for this timestamp the OpenWrt repository.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
---
 include/kernel.mk | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox

Patch

diff --git a/include/kernel.mk b/include/kernel.mk
index 432e8ce..2f477cf 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -5,6 +5,8 @@ 
 # See /LICENSE for more information.
 #
 
+SOURCE_DATE_EPOCH:=$(shell $(TOPDIR)/scripts/getsource_date_epoch.sh)
+
 ifeq ($(__target_inc),)
   include $(INCLUDE_DIR)/target.mk
 endif
@@ -21,6 +23,10 @@  else
 
   LINUX_KMOD_SUFFIX=ko
 
+  ifneq (,$(SOURCE_DATE_EPOCH))
+    export KBUILD_BUILD_TIMESTAMP=$(shell date -d @$(SOURCE_DATE_EPOCH))
+  endif
+
   ifneq (,$(findstring uml,$(BOARD)))
     KERNEL_CC?=$(HOSTCC)
     KERNEL_CROSS?=