diff mbox

[OpenWrt-Devel,3/8] at91: Translate the build all profiles profile to new multi-profile config

Message ID 1453314009-5602-3-git-send-email-openwrt@daniel.thecshore.com
State Changes Requested
Delegated to: Felix Fietkau
Headers show

Commit Message

Daniel Dickinson Jan. 20, 2016, 6:20 p.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Minor fixes so that the 'Default' profile (build all images profiles)
not only builds all profiles but acts correctly in the
new multi-profile build machinery/menuconfig.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 target/linux/at91/image/Makefile                |  6 +++++-
 target/linux/at91/legacy/profiles/00-default.mk |  3 +++
 target/linux/at91/legacy/profiles/01-unified.mk | 17 +++++++++++++++++
 target/linux/at91/legacy/target.mk              |  1 +
 target/linux/at91/sama5d3/target.mk             |  1 +
 5 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 target/linux/at91/legacy/profiles/01-unified.mk
diff mbox

Patch

diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 767255c..894e43f 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -87,13 +87,17 @@  define Image/Build/Kernel/Default
 	$(call Image/Build/Kernel/Q5XR5)
 endef
 
+define Image/Build/Kernel/Unified
+	true
+endef
+
 define Image/BuildKernel
 	mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
 		-d $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
 	if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
 		$(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
 	fi
-	$(call Image/Build/Kernel/$(PROFILE))
+	$(foreach profile,$(PROFILES_BUILD),$(call Image/Build/Kernel/$(profile)))
 endef
 
 define Image/Build
diff --git a/target/linux/at91/legacy/profiles/00-default.mk b/target/linux/at91/legacy/profiles/00-default.mk
index 3ff040d..f1c2a30 100644
--- a/target/linux/at91/legacy/profiles/00-default.mk
+++ b/target/linux/at91/legacy/profiles/00-default.mk
@@ -7,6 +7,9 @@ 
 
 define Profile/Default
 	NAME:=Default Profile
+	PROFILE_TYPE:=meta
+	PROFILE_DEFAULT:=1
+	PROFILE_IMAGES_TYPE:=all
 endef
 
 define Profile/Default/Description
diff --git a/target/linux/at91/legacy/profiles/01-unified.mk b/target/linux/at91/legacy/profiles/01-unified.mk
new file mode 100644
index 0000000..1c55897
--- /dev/null
+++ b/target/linux/at91/legacy/profiles/01-unified.mk
@@ -0,0 +1,17 @@ 
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Unified
+	NAME:=Unified Profile (merge of all selected profiles)
+	PROFILE_TYPE:=unified
+endef
+
+define Profile/Unified/Description
+	Build all selected images with a profile that is the merge of all selected profiles.
+endef
+
+$(eval $(call Profile,Unified))
diff --git a/target/linux/at91/legacy/target.mk b/target/linux/at91/legacy/target.mk
index a3d99bb..572de60 100644
--- a/target/linux/at91/legacy/target.mk
+++ b/target/linux/at91/legacy/target.mk
@@ -1,5 +1,6 @@ 
 BOARDNAME:=Legacy (ARMv5)
 CPU_TYPE:=arm926ej-s
+TARGET_MULTI_SELECT:=1
 
 define Target/Description
 	Build generic firmware for legacy Atmel AT91 platforms
diff --git a/target/linux/at91/sama5d3/target.mk b/target/linux/at91/sama5d3/target.mk
index 0319f4b..c3ebed9 100644
--- a/target/linux/at91/sama5d3/target.mk
+++ b/target/linux/at91/sama5d3/target.mk
@@ -1,5 +1,6 @@ 
 BOARDNAME:=SAMA5D3 (Cortex-A5)
 CPU_TYPE:=cortex-a5
+TARGET_MULTI_SELECT:=0
 
 DEFAULT_PACKAGES += kmod-usb2