diff mbox

[OpenWrt-Devel] package/libs/polarssl: Download location has moved and redirect is wrong

Message ID 1452409829-35356-1-git-send-email-openwrt@daniel.thecshore.com
State Changes Requested
Headers show

Commit Message

Daniel Dickinson Jan. 10, 2016, 7:10 a.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Fix the download location to the new location of the source archive
because the URI has change and redirect from the old URI is wrong

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 package/libs/polarssl/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Felix Fietkau Jan. 10, 2016, 5:27 p.m. UTC | #1
On 2016-01-10 08:10, openwrt@daniel.thecshore.com wrote:
> From: Daniel Dickinson <openwrt@daniel.thecshore.com>
> 
> Fix the download location to the new location of the source archive
> because the URI has change and redirect from the old URI is wrong
> 
> Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
> ---
>  package/libs/polarssl/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libs/polarssl/Makefile b/package/libs/polarssl/Makefile
> index e7758ae..3f584d1 100644
> --- a/package/libs/polarssl/Makefile
> +++ b/package/libs/polarssl/Makefile
> @@ -14,7 +14,7 @@ PKG_RELEASE:=1
>  PKG_USE_MIPS16:=0
>  
>  PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
> -PKG_SOURCE_URL:=https://polarssl.org/download/
> +PKG_SOURCE_URL:=https://tls.mbed.org/download/start/
And this one also doesn't work, since it points at a HTML redirect page.

- Felix
Daniel Dickinson Jan. 10, 2016, 7:37 p.m. UTC | #2
On 10/01/16 12:27 PM, Felix Fietkau wrote:
 > On 2016-01-10 08:10, openwrt@daniel.thecshore.com wrote:
 >> From: Daniel Dickinson <openwrt@daniel.thecshore.com>
 >>
 >> Fix the download location to the new location of the source archive
 >> because the URI has change and redirect from the old URI is wrong
 >>

Hmmm...looks like the first must have been a temporary outage because 
AFAICT the HTML redirect page points to the same place as the Moved 
Permanently @ the first URI.

Likely no change is actually required.

The fact it even tried the download in the first place suggests that 
something about the particular hardware/software is causing hashes to 
randomly fail (although it doesn't seem to be tied to a single machine, 
but rather narrow class of machine).

Regards,

Daniel
diff mbox

Patch

diff --git a/package/libs/polarssl/Makefile b/package/libs/polarssl/Makefile
index e7758ae..3f584d1 100644
--- a/package/libs/polarssl/Makefile
+++ b/package/libs/polarssl/Makefile
@@ -14,7 +14,7 @@  PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
-PKG_SOURCE_URL:=https://polarssl.org/download/
+PKG_SOURCE_URL:=https://tls.mbed.org/download/start/
 PKG_MD5SUM:=59662a9daaf0cfe96c349bd5ad246d1b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(SRC_PKG_NAME)-$(PKG_VERSION)