diff mbox

[OpenWrt-Devel,1/1] include/autotools.mk: rename libtool to libltdl

Message ID 1452373114-8128-1-git-send-email-xypron.glpk@gmx.de
State Superseded
Headers show

Commit Message

Heinrich Schuchardt Jan. 9, 2016, 8:58 p.m. UTC
Fixes #21567

Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
package/libs/libtool: rename to libltdl
we see warnings like

"WARNING: No feed for package 'libtool' found, maybe it's already part of
the standard packages?"

for packages with PKG_FIXUP:=libtool.

Build dependencies for libtool are generated in autotools.mk.
These have to be renamed to libltdl.

CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
CC: Felix Fietkau <nbd@openwrt.org>
Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 include/autotools.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Daniel Dickinson Jan. 9, 2016, 9:07 p.m. UTC | #1
I do not believe this is the right fix:

The PKG_NAME is libtool so the the package name
should be found as libtool not libltdl.

I have a patch I am testing that fixes the metadata.pm
issue and will correctly use libtool as the soure
package name.

Regards,

Daniel

On 09/01/16 03:58 PM, Heinrich Schuchardt wrote:
> Fixes #21567
>
> Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
> package/libs/libtool: rename to libltdl
> we see warnings like
>
> "WARNING: No feed for package 'libtool' found, maybe it's already part of
> the standard packages?"
>
> for packages with PKG_FIXUP:=libtool.
>
> Build dependencies for libtool are generated in autotools.mk.
> These have to be renamed to libltdl.
>
> CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
> CC: Felix Fietkau <nbd@openwrt.org>
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
> ---
>   include/autotools.mk | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/autotools.mk b/include/autotools.mk
> index 3316998..4d25c85 100644
> --- a/include/autotools.mk
> +++ b/include/autotools.mk
> @@ -105,14 +105,14 @@ ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
>   endif
>
>   ifneq ($(filter libtool,$(PKG_FIXUP)),)
> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>     Hooks/Configure/Pre += autoreconf_target
>    endif
>   endif
>
>   ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>     Hooks/Configure/Pre += autoreconf_target
>    endif
>
Daniel Dickinson Jan. 9, 2016, 9:15 p.m. UTC | #2
Never mind, I'm confusing source package and binary package; I'm not 
sure which this particular use depends on.

Regards,

Daniel

On 09/01/16 04:07 PM, Daniel Dickinson wrote:
> I do not believe this is the right fix:
>
> The PKG_NAME is libtool so the the package name
> should be found as libtool not libltdl.
>
> I have a patch I am testing that fixes the metadata.pm
> issue and will correctly use libtool as the soure
> package name.
>
> Regards,
>
> Daniel
>
> On 09/01/16 03:58 PM, Heinrich Schuchardt wrote:
>> Fixes #21567
>>
>> Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
>> package/libs/libtool: rename to libltdl
>> we see warnings like
>>
>> "WARNING: No feed for package 'libtool' found, maybe it's already part of
>> the standard packages?"
>>
>> for packages with PKG_FIXUP:=libtool.
>>
>> Build dependencies for libtool are generated in autotools.mk.
>> These have to be renamed to libltdl.
>>
>> CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
>> CC: Felix Fietkau <nbd@openwrt.org>
>> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
>> ---
>>   include/autotools.mk | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/include/autotools.mk b/include/autotools.mk
>> index 3316998..4d25c85 100644
>> --- a/include/autotools.mk
>> +++ b/include/autotools.mk
>> @@ -105,14 +105,14 @@ ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
>>   endif
>>
>>   ifneq ($(filter libtool,$(PKG_FIXUP)),)
>> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
>> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>>     Hooks/Configure/Pre += autoreconf_target
>>    endif
>>   endif
>>
>>   ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
>> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
>> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>>     Hooks/Configure/Pre += autoreconf_target
>>    endif
>>
Daniel Dickinson Jan. 9, 2016, 10:06 p.m. UTC | #3
Actually it turns out I was right: This depends on 'source' package not 
binary package, therefore the patch I am verifying (doing a test SDK 
compile to verify nothing broke) is required.

Regards,

Daniel

On 09/01/16 04:15 PM, Daniel Dickinson wrote:
> Never mind, I'm confusing source package and binary package; I'm not
> sure which this particular use depends on.
>
> Regards,
>
> Daniel
>
> On 09/01/16 04:07 PM, Daniel Dickinson wrote:
>> I do not believe this is the right fix:
>>
>> The PKG_NAME is libtool so the the package name
>> should be found as libtool not libltdl.
>>
>> I have a patch I am testing that fixes the metadata.pm
>> issue and will correctly use libtool as the soure
>> package name.
>>
>> Regards,
>>
>> Daniel
>>
>> On 09/01/16 03:58 PM, Heinrich Schuchardt wrote:
>>> Fixes #21567
>>>
>>> Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
>>> package/libs/libtool: rename to libltdl
>>> we see warnings like
>>>
>>> "WARNING: No feed for package 'libtool' found, maybe it's already
>>> part of
>>> the standard packages?"
>>>
>>> for packages with PKG_FIXUP:=libtool.
>>>
>>> Build dependencies for libtool are generated in autotools.mk.
>>> These have to be renamed to libltdl.
>>>
>>> CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
>>> CC: Felix Fietkau <nbd@openwrt.org>
>>> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
>>> ---
>>>   include/autotools.mk | 4 ++--
>>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/include/autotools.mk b/include/autotools.mk
>>> index 3316998..4d25c85 100644
>>> --- a/include/autotools.mk
>>> +++ b/include/autotools.mk
>>> @@ -105,14 +105,14 @@ ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
>>>   endif
>>>
>>>   ifneq ($(filter libtool,$(PKG_FIXUP)),)
>>> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
>>> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>>>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>>>     Hooks/Configure/Pre += autoreconf_target
>>>    endif
>>>   endif
>>>
>>>   ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
>>> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
>>> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>>>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>>>     Hooks/Configure/Pre += autoreconf_target
>>>    endif
>>>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Daniel Dickinson Jan. 10, 2016, 3:14 a.m. UTC | #4
The upshot of what I've figure out is that this patch is the correct 
one;  because BUILD_DEPENDS depends on 'source package name' AND 'source 
package name' is the last part of the subdir (i.e. for network/openvpn 
it would be openvpn) in which the package resides, libltdl is the new 
'source package name' for PKG_NAME:=libtool and what needs to be used 
for autoreconf dependency.

So going forward, the thing to keep in mind is that the source package 
name is not PKG_NAME but $(basename <package_subdir>).

PKG_NAME is the name of the default variant of a package (and AFIACT it 
is required that in the Makefile there exist a $(eval $(call 
BuildPackage,$(PKG_NAME)), or equivalent.

Regards,

Daniel

On 09/01/16 03:58 PM, Heinrich Schuchardt wrote:
> Fixes #21567
>
> Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
> package/libs/libtool: rename to libltdl
> we see warnings like
>
> "WARNING: No feed for package 'libtool' found, maybe it's already part of
> the standard packages?"
>
> for packages with PKG_FIXUP:=libtool.
>
> Build dependencies for libtool are generated in autotools.mk.
> These have to be renamed to libltdl.
>
> CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
> CC: Felix Fietkau <nbd@openwrt.org>
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
> ---
>   include/autotools.mk | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/autotools.mk b/include/autotools.mk
> index 3316998..4d25c85 100644
> --- a/include/autotools.mk
> +++ b/include/autotools.mk
> @@ -105,14 +105,14 @@ ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
>   endif
>
>   ifneq ($(filter libtool,$(PKG_FIXUP)),)
> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>     Hooks/Configure/Pre += autoreconf_target
>    endif
>   endif
>
>   ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
> -  PKG_BUILD_DEPENDS += libtool libintl libiconv
> +  PKG_BUILD_DEPENDS += libltdl libintl libiconv
>    ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
>     Hooks/Configure/Pre += autoreconf_target
>    endif
>
Felix Fietkau Jan. 10, 2016, 11:26 a.m. UTC | #5
On 2016-01-09 21:58, Heinrich Schuchardt wrote:
> Fixes #21567
> 
> Since commit e49896f232ed2ed76f6a67cfb6c4f9bc3ac01af
> package/libs/libtool: rename to libltdl
> we see warnings like
> 
> "WARNING: No feed for package 'libtool' found, maybe it's already part of
> the standard packages?"
> 
> for packages with PKG_FIXUP:=libtool.
> 
> Build dependencies for libtool are generated in autotools.mk.
> These have to be renamed to libltdl.
> 
> CC: Daniel Dickinson <openwrt@daniel.thecshore.com>
> CC: Felix Fietkau <nbd@openwrt.org>
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
I've found some more references to libtool in another package feed as
well, and I thought about this some more and came to the conclusion that
the rename of the core package that I suggested was a bad idea after
all. I will revert it instead of applying this patch.
Please name the source directory in the libtool package in the feed
'libtool-cross' or something like that.

- Felix
diff mbox

Patch

diff --git a/include/autotools.mk b/include/autotools.mk
index 3316998..4d25c85 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -105,14 +105,14 @@  ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
 endif
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl libiconv
+  PKG_BUILD_DEPENDS += libltdl libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl libiconv
+  PKG_BUILD_DEPENDS += libltdl libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif