diff mbox

[OpenWrt-Devel] kernel: Add kernel module for Freescale SNVS RTC on chip module

Message ID 1452248499-2730-1-git-send-email-ynezz@true.cz
State Changes Requested
Headers show

Commit Message

Petr Štetiar Jan. 8, 2016, 10:21 a.m. UTC
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 package/kernel/linux/modules/other.mk |   16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Felix Fietkau Jan. 15, 2016, 3:15 p.m. UTC | #1
On 2016-01-08 11:21, Petr Štetiar wrote:
> Signed-off-by: Petr Štetiar <ynezz@true.cz>
> ---
>  package/kernel/linux/modules/other.mk |   16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
> 
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 62fdc3c..69099a5 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -656,6 +656,22 @@ endef
>  
>  $(eval $(call KernelPackage,rtc-pt7c4338))
>  
> +define KernelPackage/rtc-snvs
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Freescale SNVS RTC support
> +  DEPENDS:=@RTC_SUPPORT
I think you should make this depend on the imx target.

- Felix
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 62fdc3c..69099a5 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -656,6 +656,22 @@  endef
 
 $(eval $(call KernelPackage,rtc-pt7c4338))
 
+define KernelPackage/rtc-snvs
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Freescale SNVS RTC support
+  DEPENDS:=@RTC_SUPPORT
+  KCONFIG:=CONFIG_RTC_DRV_SNVS \
+	CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-snvs.ko
+  AUTOLOAD:=$(call AutoProbe,rtc-snvs)
+endef
+
+define KernelPackage/rtc-snvs/description
+ Kernel module for Freescale SNVS RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-snvs))
+
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)