diff mbox

[OpenWrt-Devel] Add @APACHE download facility

Message ID 1452112222-29586-1-git-send-email-xypron.glpk@gmx.de
State Accepted
Headers show

Commit Message

Heinrich Schuchardt Jan. 6, 2016, 8:30 p.m. UTC
The Apache Software Foundation offers diverse download mirros.

For packaging Apache software a new alias @APACHE is defined.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 include/download.mk | 2 +-
 scripts/download.pl | 6 ++++++
 2 files changed, 7 insertions(+), 1 deletion(-)

Comments

Heinrich Schuchardt Jan. 17, 2016, 10:26 a.m. UTC | #1
I would like to package subversion.
The patch below is a prerequisite.

Best regards

Heinrich Schuchardt

On 01/06/2016 09:30 PM, Heinrich Schuchardt wrote:
> The Apache Software Foundation offers diverse download mirros.
> 
> For packaging Apache software a new alias @APACHE is defined.
> 
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
> ---
>  include/download.mk | 2 +-
>  scripts/download.pl | 6 ++++++
>  2 files changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/include/download.mk b/include/download.mk
> index c551647..7b7aa4a 100644
> --- a/include/download.mk
> +++ b/include/download.mk
> @@ -11,7 +11,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
>  define dl_method
>  $(strip \
>    $(if $(2),$(2), \
> -    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
> +    $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
>        $(if $(filter git://%,$(1)),git, \
>          $(if $(filter svn://%,$(1)),svn, \
>            $(if $(filter cvs://%,$(1)),cvs, \
> diff --git a/scripts/download.pl b/scripts/download.pl
> index 6f28237..09d492c 100755
> --- a/scripts/download.pl
> +++ b/scripts/download.pl
> @@ -158,6 +158,12 @@ foreach my $mirror (@ARGV) {
>  		for (1 .. 5) {
>  			push @mirrors, "http://downloads.sourceforge.net/$1";
>  		}
> +	} elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
> +		push @mirrors, "http://ftp.tudelft.nl/apache/$1";
> +		push @mirrors, "http://apache.openmirror.de/$1";
> +		push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
> +		push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
> +		push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
>  	} elsif ($mirror =~ /^\@GNU\/(.+)$/) {
>  		push @mirrors, "http://ftpmirror.gnu.org/$1";
>  		push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";
>
diff mbox

Patch

diff --git a/include/download.mk b/include/download.mk
index c551647..7b7aa4a 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -11,7 +11,7 @@  DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 define dl_method
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+    $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \
diff --git a/scripts/download.pl b/scripts/download.pl
index 6f28237..09d492c 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -158,6 +158,12 @@  foreach my $mirror (@ARGV) {
 		for (1 .. 5) {
 			push @mirrors, "http://downloads.sourceforge.net/$1";
 		}
+	} elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
+		push @mirrors, "http://ftp.tudelft.nl/apache/$1";
+		push @mirrors, "http://apache.openmirror.de/$1";
+		push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
+		push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
+		push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
 	} elsif ($mirror =~ /^\@GNU\/(.+)$/) {
 		push @mirrors, "http://ftpmirror.gnu.org/$1";
 		push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";