diff mbox

[OpenWrt-Devel,1/1,v2] package/libs/libtool: rename to libltdl

Message ID 1451867690-19674-1-git-send-email-xypron.glpk@gmx.de
State Changes Requested
Headers show

Commit Message

Heinrich Schuchardt Jan. 4, 2016, 12:34 a.m. UTC
Source package libtool is used to package libltdl.
Unfortunately binary libtoolize is missing.
Packaging libtoolize would depend on package file which is in the
packages feed.
Felix Fietkau suggested to rename source libtool to libltdl
and to create a new package libtool in packages.

This patch contains the renaming.

version 2
	Renaming must occur inside Makefile too.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 package/libs/libltdl/Makefile                      | 60 ++++++++++++++++++++++
 .../libs/libltdl/patches/160-passthrough-ssp.patch | 11 ++++
 package/libs/libtool/Makefile                      | 52 -------------------
 .../libs/libtool/patches/160-passthrough-ssp.patch | 11 ----
 4 files changed, 71 insertions(+), 63 deletions(-)
 create mode 100644 package/libs/libltdl/Makefile
 create mode 100644 package/libs/libltdl/patches/160-passthrough-ssp.patch
 delete mode 100644 package/libs/libtool/Makefile
 delete mode 100644 package/libs/libtool/patches/160-passthrough-ssp.patch

Comments

Felix Fietkau Jan. 4, 2016, 12:43 a.m. UTC | #1
On 2016-01-04 01:34, Heinrich Schuchardt wrote:
> Source package libtool is used to package libltdl.
> Unfortunately binary libtoolize is missing.
> Packaging libtoolize would depend on package file which is in the
> packages feed.
> Felix Fietkau suggested to rename source libtool to libltdl
> and to create a new package libtool in packages.
> 
> This patch contains the renaming.
> 
> version 2
> 	Renaming must occur inside Makefile too.
That Build/Prepare code is rather weird. How about leaving PKG_NAME
alone, removing Build/Prepare and just setting:
PKG_BUILD_DIR:=$(BUILD_DIR)/libltdl/$(PKG_NAME)-$(PKG_VERSION)

- Felix
Heinrich Schuchardt Jan. 4, 2016, 1:23 a.m. UTC | #2
On 04.01.2016 01:43, Felix Fietkau wrote:
> On 2016-01-04 01:34, Heinrich Schuchardt wrote:
>> Source package libtool is used to package libltdl.
>> Unfortunately binary libtoolize is missing.
>> Packaging libtoolize would depend on package file which is in the
>> packages feed.
>> Felix Fietkau suggested to rename source libtool to libltdl
>> and to create a new package libtool in packages.
>>
>> This patch contains the renaming.
>>
>> version 2
>> 	Renaming must occur inside Makefile too.
> That Build/Prepare code is rather weird. How about leaving PKG_NAME
> alone, removing Build/Prepare and just setting:
> PKG_BUILD_DIR:=$(BUILD_DIR)/libltdl/$(PKG_NAME)-$(PKG_VERSION)
> 
> - Felix
> 
Does variable PKG_NAME have no significance outside?
Doesn't it have to match the directory name?

What I want to avoid is that if I create
devel/libtool/Makefile with PKG_NAME=libtool
in feed packages I get any interference.

Unfortunately wiki.openwrt.org does not really explain this.

It seems that something like you propose has already be done in
package/kernel/lantiq/ltq-adsl-fw/Makefile

Best regards

Heinrich
Felix Fietkau Jan. 4, 2016, 1:37 a.m. UTC | #3
On 2016-01-04 02:23, Heinrich Schuchardt wrote:
> On 04.01.2016 01:43, Felix Fietkau wrote:
>> On 2016-01-04 01:34, Heinrich Schuchardt wrote:
>>> Source package libtool is used to package libltdl.
>>> Unfortunately binary libtoolize is missing.
>>> Packaging libtoolize would depend on package file which is in the
>>> packages feed.
>>> Felix Fietkau suggested to rename source libtool to libltdl
>>> and to create a new package libtool in packages.
>>>
>>> This patch contains the renaming.
>>>
>>> version 2
>>> 	Renaming must occur inside Makefile too.
>> That Build/Prepare code is rather weird. How about leaving PKG_NAME
>> alone, removing Build/Prepare and just setting:
>> PKG_BUILD_DIR:=$(BUILD_DIR)/libltdl/$(PKG_NAME)-$(PKG_VERSION)
>> 
>> - Felix
>> 
> Does variable PKG_NAME have no significance outside?
There were some instances where it was used that might have triggered
some rare race conditions, but I just fixed those in r48110.

> Doesn't it have to match the directory name?
It doesn't.

> What I want to avoid is that if I create
> devel/libtool/Makefile with PKG_NAME=libtool
> in feed packages I get any interference.
You can safely do that.

- Felix
diff mbox

Patch

diff --git a/package/libs/libltdl/Makefile b/package/libs/libltdl/Makefile
new file mode 100644
index 0000000..3401caa
--- /dev/null
+++ b/package/libs/libltdl/Makefile
@@ -0,0 +1,60 @@ 
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libltdl
+PKG_VERSION:=2.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=libtool-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libtool
+PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_PARALLEL:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_PREFIX=$(STAGING_DIR)/host
+export GLOBAL_LIBDIR=$(STAGING_DIR)/usr/lib
+
+define Package/libltdl
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A generic dynamic object loading library
+  URL:=http://www.gnu.org/software/libtool/
+endef
+
+define Build/Prepare
+	rm -rf $(PKG_BUILD_DIR)
+	mkdir -p $(PKG_BUILD_DIR)
+	$(TAR) -C $(PKG_BUILD_DIR) \
+	  -xzf $(DL_DIR)/libtool-$(PKG_VERSION).tar.gz --strip 1
+	$(Build/Patch)
+endef
+
+define Build/InstallDev
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		bindir="$(2)/bin" \
+		datadir="$(2)/share" \
+		prefix="$(2)" \
+		exec_prefix="$(2)" \
+		install
+	$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
+	mv $(2)/lib/* $(1)/usr/lib/
+	mv $(2)/include/* $(1)/usr/include/
+endef
+
+define Package/libltdl/install
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libltdl))
diff --git a/package/libs/libltdl/patches/160-passthrough-ssp.patch b/package/libs/libltdl/patches/160-passthrough-ssp.patch
new file mode 100644
index 0000000..6fcbe68
--- /dev/null
+++ b/package/libs/libltdl/patches/160-passthrough-ssp.patch
@@ -0,0 +1,11 @@ 
+--- a/libltdl/config/ltmain.m4sh
++++ b/libltdl/config/ltmain.m4sh
+@@ -5051,7 +5051,7 @@ func_mode_link ()
+       # -O*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
+       -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
+       -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
+-      -O*|-flto*|-fwhopr*|-fuse-linker-plugin)
++      -O*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*)
+         func_quote_for_eval "$arg"
+ 	arg="$func_quote_for_eval_result"
+         func_append compile_command " $arg"
diff --git a/package/libs/libtool/Makefile b/package/libs/libtool/Makefile
deleted file mode 100644
index 8091081..0000000
--- a/package/libs/libtool/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@ 
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libtool
-PKG_VERSION:=2.4
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
-
-PKG_LICENSE:=GPL-2.0+
-PKG_LICENSE_FILES:=COPYING
-
-PKG_BUILD_PARALLEL:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-CONFIGURE_PREFIX=$(STAGING_DIR)/host
-export GLOBAL_LIBDIR=$(STAGING_DIR)/usr/lib
-
-define Package/libltdl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=A generic dynamic object loading library
-  URL:=http://www.gnu.org/software/libtool/
-endef
-
-define Build/InstallDev
-	$(MAKE) -C $(PKG_BUILD_DIR) \
-		bindir="$(2)/bin" \
-		datadir="$(2)/share" \
-		prefix="$(2)" \
-		exec_prefix="$(2)" \
-		install
-	$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
-	mv $(2)/lib/* $(1)/usr/lib/
-	mv $(2)/include/* $(1)/usr/include/
-endef
-
-define Package/libltdl/install
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libltdl))
diff --git a/package/libs/libtool/patches/160-passthrough-ssp.patch b/package/libs/libtool/patches/160-passthrough-ssp.patch
deleted file mode 100644
index 6fcbe68..0000000
--- a/package/libs/libtool/patches/160-passthrough-ssp.patch
+++ /dev/null
@@ -1,11 +0,0 @@ 
---- a/libltdl/config/ltmain.m4sh
-+++ b/libltdl/config/ltmain.m4sh
-@@ -5051,7 +5051,7 @@ func_mode_link ()
-       # -O*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
-       -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
-       -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
--      -O*|-flto*|-fwhopr*|-fuse-linker-plugin)
-+      -O*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*)
-         func_quote_for_eval "$arg"
- 	arg="$func_quote_for_eval_result"
-         func_append compile_command " $arg"