diff mbox

[OpenWrt-Devel,v2] 6in4: Corrected tunnelbroker tunnel update URL

Message ID 1451181617-11161-1-git-send-email-sami@olmari.fi
State Accepted
Headers show

Commit Message

Sami Olmari Dec. 27, 2015, 2 a.m. UTC
Changed the tunnel update URL into format tunnelbrokers
example has, that made it work again. Current method gives "Username/Password
Authentication Failed." when I tried the wget line manually and logread
eventually says also "6in4: update failed". With corrected URL it works fine:
"good 111.222.333.444" or "nochg 111.222.333.444" and logread concurs with
success, and tunnel actually updates.

Tested-by: Vaasa Hacklab <info@vaasa.hacklab.fi>
Signed-off-by: Sami Olmari <sami@olmari.fi>
---
 package/network/ipv6/6in4/Makefile      | 2 +-
 package/network/ipv6/6in4/files/6in4.sh | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 9eca57a..b51b12d 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=22
+PKG_VERSION:=23
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 59747a3..05471db 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -108,7 +108,7 @@  proto_6in4_setup() {
 			fi
 		}
 
-		local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+		local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
 		local try=0
 		local max=3