diff mbox

[OpenWrt-Devel,6/9] ar71xx: Image generation for PowerCloud CR5000 Cloud Router

Message ID 1450392667-22656-7-git-send-email-openwrt@daniel.thecshore.com
State Accepted
Headers show

Commit Message

Daniel Dickinson Dec. 17, 2015, 10:51 p.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Kernel part of support for the PowerCloud Systems CR5000.  The
CR5000 is a dual-band 802.11n wireless router with 8MB flash,
64 MB RAM, (unused in stock firmware) USB 2.0 port, and five
port gigabit ethernet switch.  The CR5000 was sold as hardware for
the Skydog cloud-managed router service.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 target/linux/ar71xx/generic/profiles/pcs.mk | 18 ++++++++++++++++++
 target/linux/ar71xx/image/Makefile          | 18 ++++++++++++++++++
 2 files changed, 36 insertions(+)
diff mbox

Patch

diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
index b4df1a4..e48b3bd 100644
--- a/target/linux/ar71xx/generic/profiles/pcs.mk
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -65,3 +65,21 @@  endef
 
 $(eval $(call Profile,CR3000))
 
+define Profile/CR5000
+	NAME:=PowerCloud CR5000 Cloud Router
+	PACKAGES:=uboot-envtools kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev kmod-usb-core
+endef
+
+define Profile/CR5000/Description
+	Package set optimized for the PowerCloud Systems CR5000 Cloud Router
+
+	The CR5000 is a device sold by PowerCloud Systems as a hardware
+	option for their Skydog cloud-managed Wifi solution.
+
+	The CR5000 is a dual band GHz 802.11n wireless router with 8MB
+	flash and 64MB RAM, a five port gigabit switch and a USB 2.0
+	port which was unused in the stock firmware.
+endef
+
+$(eval $(call Profile,CR5000))
+
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index af9516e..61c76a3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -427,6 +427,24 @@  endef
 
 TARGET_DEVICES += cr3000-nocloud
 
+define Device/cr5000
+  BOARDNAME := CR5000
+  DEVICE_PROFILE := CR5000
+  IMAGE_SIZE = 7104k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7104k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cr5000
+
+define Device/cr5000-nocloud
+  BOARDNAME := CR5000
+  DEVICE_PROFILE := CR5000
+  IMAGE_SIZE = 7808k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7808k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cr5000-nocloud
+
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
     BOARDNAME := ANTMINER-S1