diff mbox

[OpenWrt-Devel] package/kernel: Build it87 hardware monitor module

Message ID 1450303840-107231-1-git-send-email-openwrt@daniel.thecshore.com
State Changes Requested
Headers show

Commit Message

Daniel Dickinson Dec. 16, 2015, 10:10 p.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

Fixed typo in description define.

This is easily added with no side effects, not sure why it
was missing - oversight?

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 package/kernel/linux/modules/hwmon.mk | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

John Crispin Dec. 17, 2015, 8:56 a.m. UTC | #1
you know how to write proper descriptions for patches. i have seen you
do it many times over many years. i wont even explain to you what is
wrong with this one.

please fix and resend.
	John

On 16/12/2015 23:10, openwrt@daniel.thecshore.com wrote:
> From: Daniel Dickinson <openwrt@daniel.thecshore.com>
> 
> Fixed typo in description define.
> 
> This is easily added with no side effects, not sure why it
> was missing - oversight?
> 
> Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
> ---
>  package/kernel/linux/modules/hwmon.mk | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
> 
> diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
> index ca0ff66..97bef4d 100644
> --- a/package/kernel/linux/modules/hwmon.mk
> +++ b/package/kernel/linux/modules/hwmon.mk
> @@ -93,6 +93,20 @@ endef
>  $(eval $(call KernelPackage,hwmon-ina2xx))
>  
>  
> +define KernelPackage/hwmon-it87
> +  TITLE:=it87 monitoring support
> +  KCONFIG:=CONFIG_SENSORS_IT87
> +  FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
> +  AUTOLOAD:=$(call AutoProbe,it87)
> +  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmod-vid)
> +endef
> +
> +define KernelPackage/hwmon-it87/description
> + Kernel module for it87 thermal and voltage monitor chip
> +endef
> +
> +$(eval $(call KernelPackage,hwmon-it87))
> +
>  define KernelPackage/hwmon-lm63
>    TITLE:=LM63/64 monitoring support
>    KCONFIG:=CONFIG_SENSORS_LM63
>
diff mbox

Patch

diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ca0ff66..97bef4d 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -93,6 +93,20 @@  endef
 $(eval $(call KernelPackage,hwmon-ina2xx))
 
 
+define KernelPackage/hwmon-it87
+  TITLE:=it87 monitoring support
+  KCONFIG:=CONFIG_SENSORS_IT87
+  FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+  AUTOLOAD:=$(call AutoProbe,it87)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmod-vid)
+endef
+
+define KernelPackage/hwmon-it87/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63