diff mbox

[OpenWrt-Devel] package/kernel: Build it87 hardware monitor module

Message ID 1450295460-83100-1-git-send-email-openwrt@daniel.thecshore.com
State Changes Requested
Headers show

Commit Message

Daniel Dickinson Dec. 16, 2015, 7:51 p.m. UTC
From: Daniel Dickinson <openwrt@daniel.thecshore.com>

This is easy to add with no side effects; the chip probably just got added after
the hwmon package was created and never got included in builds.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
---
 package/kernel/linux/modules/hwmon.mk | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Bjørn Mork Dec. 16, 2015, 8:07 p.m. UTC | #1
openwrt@daniel.thecshore.com writes:

> From: Daniel Dickinson <openwrt@daniel.thecshore.com>
>
> This is easy to add with no side effects; the chip probably just got added after
> the hwmon package was created

I sort of doubt that...  I remember messing with that driver a long time
ago, in a galaxy far far away.  Google tells me that was 2004 and Linux
v2.6.6.  Let's see, Google also tells me White Russian was released in
2007.

Anyway. Small typo here:

> +define KernelPackage/hwmon-i687/description


Bjørn
diff mbox

Patch

diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ca0ff66..f260e27 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -93,6 +93,20 @@  endef
 $(eval $(call KernelPackage,hwmon-ina2xx))
 
 
+define KernelPackage/hwmon-it87
+  TITLE:=it87 monitoring support
+  KCONFIG:=CONFIG_SENSORS_IT87
+  FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+  AUTOLOAD:=$(call AutoProbe,it87)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmod-vid)
+endef
+
+define KernelPackage/hwmon-i687/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63