diff mbox

[OpenWrt-Devel] kernel: kmod-ptp selects a new config symbol

Message ID 1450135377-840-1-git-send-email-dirkneukirchen@web.de
State Accepted
Headers show

Commit Message

Dirk Neukirchen Dec. 14, 2015, 11:22 p.m. UTC
since Kernel 3.14
408eccce net: ptp: move PTP classifier in its own file

found while bug search
thx olmari on IRC

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/other.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9bb9dec..62fdc3c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -820,7 +820,9 @@  define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support
   DEPENDS:=+kmod-pps
-  KCONFIG:=CONFIG_PTP_1588_CLOCK
+  KCONFIG:= \
+	CONFIG_PTP_1588_CLOCK \
+	CONFIG_NET_PTP_CLASSIFY=y
   FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
   AUTOLOAD:=$(call AutoLoad,18,ptp,1)
 endef