diff mbox

[OpenWrt-Devel] ar71xx: build image for TL-WR710N v2.1

Message ID 1448825409-26827-1-git-send-email-nw@wegener-net.de
State Superseded
Headers show

Commit Message

Norbert Wegener Nov. 29, 2015, 7:30 p.m. UTC
# This patch just extends target/linux/ar71xx/image/Makefile to build
# images also for version 2.1 of TL-WR710N
# patch against the latest git

# Signed off by: Norbert Wegener <nw@wegener-net.de>
---
 target/linux/ar71xx/image/Makefile | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

John Crispin Nov. 30, 2015, 6:53 a.m. UTC | #1
On 29/11/2015 20:30, Norbert Wegener wrote:
> # This patch just extends target/linux/ar71xx/image/Makefile to build
> # images also for version 2.1 of TL-WR710N
> # patch against the latest git
> 
> # Signed off by: Norbert Wegener <nw@wegener-net.de>

the "#" are not needed. please remove them

	John

> ---
>  target/linux/ar71xx/image/Makefile | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index d12ad8b..74d26ef 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -596,6 +596,15 @@ define Device/tl-wr710n-v2
>      CONSOLE := ttyATH0,115200
>  endef
>  
> +define Device/tl-wr710n-v2.1
> +    $(Device/tplink-8mlzma)
> +    BOARDNAME := TL-WR710N
> +    DEVICE_PROFILE := TLWR710
> +    TPLINK_HWID := 0x07100002
> +    TPLINK_HWREV := 0x00000002
> +    CONSOLE := ttyATH0,115200
> +endef
> +
>  define Device/tl-wr720n-v3
>      $(Device/tplink-4mlzma)
>      BOARDNAME := TL-WR720N-v3
> @@ -611,7 +620,7 @@ define Device/tl-wr720n-v4
>      TPLINK_HWID := 0x07200104
>      CONSOLE := ttyATH0,115200
>  endef
> -TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
> +TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr710n-v2.1 tl-wr720n-v3 tl-wr720n-v4
>  
>  define Device/tl-wr740n-v1
>      $(Device/tplink-4m)
>
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d12ad8b..74d26ef 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -596,6 +596,15 @@  define Device/tl-wr710n-v2
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr710n-v2.1
+    $(Device/tplink-8mlzma)
+    BOARDNAME := TL-WR710N
+    DEVICE_PROFILE := TLWR710
+    TPLINK_HWID := 0x07100002
+    TPLINK_HWREV := 0x00000002
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr720n-v3
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WR720N-v3
@@ -611,7 +620,7 @@  define Device/tl-wr720n-v4
     TPLINK_HWID := 0x07200104
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr710n-v2.1 tl-wr720n-v3 tl-wr720n-v4
 
 define Device/tl-wr740n-v1
     $(Device/tplink-4m)