diff mbox

[OpenWrt-Devel] mac80211: Add dependency on ip (iproute2) to cfg80211

Message ID 1447702096-5497-1-git-send-email-thess@kitschensync.net
State Rejected
Headers show

Commit Message

Ted Hess Nov. 16, 2015, 7:28 p.m. UTC
Changes to netifd/wireless/mac80211.sh in r46832 invoke 'ip' when making
a client association. 'ip' is not automatically included with cfg80211
custom builds -- association fails.

Signed-off-by: Ted Hess <thess@kitschensync.net>
---
 package/kernel/mac80211/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Felix Fietkau Nov. 16, 2015, 11:40 p.m. UTC | #1
On 2015-11-16 20:28, Ted Hess wrote:
> Changes to netifd/wireless/mac80211.sh in r46832 invoke 'ip' when making
> a client association. 'ip' is not automatically included with cfg80211
> custom builds -- association fails.
> 
> Signed-off-by: Ted Hess <thess@kitschensync.net>
NACK. These changes were added because the busybox ip applet was enabled
by default recently.

- Felix
Cristian Morales Vega Nov. 17, 2015, 8:10 a.m. UTC | #2
On 16 November 2015 at 23:40, Felix Fietkau <nbd@openwrt.org> wrote:
> On 2015-11-16 20:28, Ted Hess wrote:
>> Changes to netifd/wireless/mac80211.sh in r46832 invoke 'ip' when making
>> a client association. 'ip' is not automatically included with cfg80211
>> custom builds -- association fails.
>>
>> Signed-off-by: Ted Hess <thess@kitschensync.net>
> NACK. These changes were added because the busybox ip applet was enabled
> by default recently.

So there is a dependency (ip package OR ip support in Busybox), but no
way to express it?

Not that it would make sense for anybody to disable the new default in
busybox without enabling the ip package at the same time. Just
curious.
Luiz Angelo Daros de Luca Nov. 17, 2015, 11:59 a.m. UTC | #3
Is there a way to add "provides" to a package? In RPM, I would solve this
adding "Provides: ip" to busybox.

This could also help when a kern module gets built-in. Kernel package could
provide the incorporated kmod-xxx module. It would be better if both kernel
and kmod-xxx could automatically provide every single module it provides,
so packages could requires modules and not their packages, whether it is
built-in or loadable module.

Just like the case of busybox, if someone changes a module to not be
built-in (a configuration), it will require a code (makefile) change in
order to fix broken deps.

Luiz

Em ter, 17 de nov de 2015 06:11, Cristian Morales Vega <
cristian@samknows.com> escreveu:

> On 16 November 2015 at 23:40, Felix Fietkau <nbd@openwrt.org> wrote:
> > On 2015-11-16 20:28, Ted Hess wrote:
> >> Changes to netifd/wireless/mac80211.sh in r46832 invoke 'ip' when making
> >> a client association. 'ip' is not automatically included with cfg80211
> >> custom builds -- association fails.
> >>
> >> Signed-off-by: Ted Hess <thess@kitschensync.net>
> > NACK. These changes were added because the busybox ip applet was enabled
> > by default recently.
>
> So there is a dependency (ip package OR ip support in Busybox), but no
> way to express it?
>
> Not that it would make sense for anybody to disable the new default in
> busybox without enabling the ip package at the same time. Just
> curious.
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Felix Fietkau Nov. 17, 2015, 12:03 p.m. UTC | #4
On 2015-11-17 12:59, Luiz Angelo Daros de Luca wrote:
> Is there a way to add "provides" to a package? In RPM, I would solve
> this adding "Provides: ip" to busybox.
> 
> This could also help when a kern module gets built-in. Kernel package
> could provide the incorporated kmod-xxx module. It would be better if
> both kernel and kmod-xxx could automatically provide every single module
> it provides, so packages could requires modules and not their packages,
> whether it is built-in or loadable module.
> 
> Just like the case of busybox, if someone changes a module to not be
> built-in (a configuration), it will require a code (makefile) change in
> order to fix broken deps.
I personally think changing package metadata for this this is a waste of
time. There are so many different ways in which you can screw up a build
by customizing the busybox configuration, and it would be a futile
effort to try to add checks for them all.

People that customize their busybox config should just check the output
of ./scripts/diffconfig.sh for any missing options if they run into any
issues. Problematic changes are typically very easily visible there,
since the output contains very few items aside from changes directly
made by the user or options that went out of sync with the default
configuration.

- Felix
diff mbox

Patch

diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index f2427de..8d5c302 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -78,7 +78,7 @@  endef
 define KernelPackage/cfg80211
   $(call KernelPackage/mac80211/Default)
   TITLE:=cfg80211 - wireless configuration API
-  DEPENDS+= +iw
+  DEPENDS+= +iw +ip
   FILES:= \
 	$(PKG_BUILD_DIR)/compat/compat.ko \
 	$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko