diff mbox

[OpenWrt-Devel] ar71xx: Add support for wdr7500v3

Message ID 1446017222-28027-2-git-send-email-srdjan.rosic@gmail.com
State Accepted
Headers show

Commit Message

Srdjan Rosic Oct. 28, 2015, 7:27 a.m. UTC
The device is similar to Archer C7 v2, but with 8M of flash, and 6 external
antennas.  Reason for breaking the naming pattern is that sticker on the back
mentions "WDR7500" and has no mention of "Archer".

Signed-off-by: Srdjan Rosic <rosic@google.com>
---
 target/linux/ar71xx/image/Makefile | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a659af9..8f7aae0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -369,7 +369,14 @@  define Device/archer-c7-v2
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
 endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+    $(Device/tplink-8mlzma)
+    BOARDNAME := ARCHER-C7
+    DEVICE_PROFILE := ARCHERC7
+    TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
 define Device/antminer-s1
     $(Device/tplink-8mlzma)