diff mbox

[OpenWrt-Devel] Add initial support for wdr7500v3

Message ID 1445982192-19813-2-git-send-email-srdjan.rosic@gmail.com
State Superseded
Headers show

Commit Message

Srdjan Rosic Oct. 27, 2015, 9:43 p.m. UTC
Signed-off-by: Srdjan Rosic <rosic@google.com>
---
 target/linux/ar71xx/image/Makefile | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Rafał Miłecki Oct. 27, 2015, 10:06 p.m. UTC | #1
On 27 October 2015 at 22:43, Srdjan Rosic <srdjan.rosic@gmail.com> wrote:
> Signed-off-by: Srdjan Rosic <rosic@google.com>

Please use a correct prefix for your patches, you can get an idea by
looking at the log, e.g.:
git log --one-line target/linux/ar71xx/

This should be something like:
ar71xx: Add initial support for wdr7500v3

Not sure if maintainer will want you to resend or will fix it on his own.
Srdjan Rosic Oct. 27, 2015, 10:12 p.m. UTC | #2
Ooops, it's my first patch to openwrt and I didn't know :(
I'm fine with resending, but I'd prefer if there are other changes I
should make to make them in one batch to not spam the list with new
threads.

Thank you,
-s

On Tue, Oct 27, 2015 at 10:06 PM, Rafał Miłecki <zajec5@gmail.com> wrote:
> On 27 October 2015 at 22:43, Srdjan Rosic <srdjan.rosic@gmail.com> wrote:
>> Signed-off-by: Srdjan Rosic <rosic@google.com>
>
> Please use a correct prefix for your patches, you can get an idea by
> looking at the log, e.g.:
> git log --one-line target/linux/ar71xx/
>
> This should be something like:
> ar71xx: Add initial support for wdr7500v3
>
> Not sure if maintainer will want you to resend or will fix it on his own.
Srdjan Rosic Oct. 28, 2015, 7:28 a.m. UTC | #3
Fixed the commit messages and resent.
Please ignore this thread, and look for one prefixed with ar71xx
Srdjan Rosic


On Tue, Oct 27, 2015 at 10:12 PM, Srdjan Rosic <srdjan.rosic@gmail.com> wrote:
> Ooops, it's my first patch to openwrt and I didn't know :(
> I'm fine with resending, but I'd prefer if there are other changes I
> should make to make them in one batch to not spam the list with new
> threads.
>
> Thank you,
> -s
>
> On Tue, Oct 27, 2015 at 10:06 PM, Rafał Miłecki <zajec5@gmail.com> wrote:
>> On 27 October 2015 at 22:43, Srdjan Rosic <srdjan.rosic@gmail.com> wrote:
>>> Signed-off-by: Srdjan Rosic <rosic@google.com>
>>
>> Please use a correct prefix for your patches, you can get an idea by
>> looking at the log, e.g.:
>> git log --one-line target/linux/ar71xx/
>>
>> This should be something like:
>> ar71xx: Add initial support for wdr7500v3
>>
>> Not sure if maintainer will want you to resend or will fix it on his own.
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a659af9..8f7aae0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -369,7 +369,14 @@  define Device/archer-c7-v2
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
 endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+    $(Device/tplink-8mlzma)
+    BOARDNAME := ARCHER-C7
+    DEVICE_PROFILE := ARCHERC7
+    TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
 define Device/antminer-s1
     $(Device/tplink-8mlzma)