diff mbox

[OpenWrt-Devel] libnl: Install include files into libnl3

Message ID 1443724058-310-1-git-send-email-br1@einfach.org
State Accepted
Headers show

Commit Message

Bruno Randolf Oct. 1, 2015, 6:27 p.m. UTC
Install header files into same location as pkgconfig/libnl-3.0.pc says:
  Cflags: -I${includedir}/libnl3

Signed-off-by: Bruno Randolf <br1@einfach.org>
---
 package/libs/libnl/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Paul Fertser Oct. 2, 2015, 6:01 a.m. UTC | #1
Bruno Randolf <br1@einfach.org> writes:
> Install header files into same location as pkgconfig/libnl-3.0.pc says:
>   Cflags: -I${includedir}/libnl3

For the reference, I've sent a similar patch [1] but have forgotten to
modify the INSTALL_DIR line.

[1] http://patchwork.ozlabs.org/patch/524877/
diff mbox

Patch

diff --git a/package/libs/libnl/Makefile b/package/libs/libnl/Makefile
index 857bbe2..241e9a7 100644
--- a/package/libs/libnl/Makefile
+++ b/package/libs/libnl/Makefile
@@ -85,8 +85,8 @@  define Build/Compile
 endef
 
 define Build/InstallDev
-	$(INSTALL_DIR) $(1)/usr/include/libnl $(1)/usr/lib/pkgconfig
-	$(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl/
+	$(INSTALL_DIR) $(1)/usr/include/libnl3 $(1)/usr/lib/pkgconfig
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl3/
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig