diff mbox

[OpenWrt-Devel] target/mpc85xx: add cuImage.tl-wdr4900-v1 kernel image if CONFIG_TL_WDR4900_V1=y

Message ID 1442913914-30638-1-git-send-email-ardeleanalex@gmail.com
State Superseded
Headers show

Commit Message

Alexandru Ardelean Sept. 22, 2015, 9:25 a.m. UTC
From: Alexandru Ardelean <aa@ocedo.com>

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 target/linux/mpc85xx/Makefile | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Matthias Schiffer Sept. 22, 2015, 1:05 p.m. UTC | #1
On 09/22/2015 06:25 PM, Alexandru Ardelean wrote:
> From: Alexandru Ardelean <aa@ocedo.com>
> 
> Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
> ---
>  target/linux/mpc85xx/Makefile | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
> index e43327a..bfc2c8d 100644
> --- a/target/linux/mpc85xx/Makefile
> +++ b/target/linux/mpc85xx/Makefile
> @@ -16,7 +16,10 @@ SUBTARGETS=generic p1020
>  
>  KERNEL_PATCHVER:=3.18
>  
> -KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
> +KERNEL_IMAGES := zImage
> +ifeq ($(CONFIG_TL_WDR4900_V1),y)
> +KERNEL_IMAGES += cuImage.tl-wdr4900-v1
> +endif
>  
>  include $(INCLUDE_DIR)/target.mk
>  
> 

This doesn't work, CONFIG_TL_WDR4900_V1 is a kernel .config option, not
a OpenWrt .config option, and thus isn't available in OpenWrt Makefiles.
What is this supposed to fix?
Alexandru Ardelean Sept. 22, 2015, 1:11 p.m. UTC | #2
On Tue, Sep 22, 2015 at 4:05 PM, Matthias Schiffer <
mschiffer@universe-factory.net> wrote:

> On 09/22/2015 06:25 PM, Alexandru Ardelean wrote:
> > From: Alexandru Ardelean <aa@ocedo.com>
> >
> > Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
> > ---
> >  target/linux/mpc85xx/Makefile | 5 ++++-
> >  1 file changed, 4 insertions(+), 1 deletion(-)
> >
> > diff --git a/target/linux/mpc85xx/Makefile
> b/target/linux/mpc85xx/Makefile
> > index e43327a..bfc2c8d 100644
> > --- a/target/linux/mpc85xx/Makefile
> > +++ b/target/linux/mpc85xx/Makefile
> > @@ -16,7 +16,10 @@ SUBTARGETS=generic p1020
> >
> >  KERNEL_PATCHVER:=3.18
> >
> > -KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
> > +KERNEL_IMAGES := zImage
> > +ifeq ($(CONFIG_TL_WDR4900_V1),y)
> > +KERNEL_IMAGES += cuImage.tl-wdr4900-v1
> > +endif
> >
> >  include $(INCLUDE_DIR)/target.mk
> >
> >
>
> This doesn't work, CONFIG_TL_WDR4900_V1 is a kernel .config option, not
> a OpenWrt .config option, and thus isn't available in OpenWrt Makefiles.
> What is this supposed to fix?
>

Seems I'm confused here with the makefiles.

For our case, removing that kernel image file is needed, because we build
our own mpc85xx image that is different from wdr4900-v1 ; so no file named
cuImage.tl-wdr4900-v1.
Ideally, I'd like to put it under a config option that disables/enables
this ; I will admit that I haven't tried the case where this is on.

I'll try to find another option that disables this, that can also enable it.
Any suggestions ?
Felix Fietkau Sept. 22, 2015, 1:45 p.m. UTC | #3
On 2015-09-22 15:11, Alexandru Ardelean wrote:
> 
> 
> On Tue, Sep 22, 2015 at 4:05 PM, Matthias Schiffer
> <mschiffer@universe-factory.net <mailto:mschiffer@universe-factory.net>>
> wrote:
> 
>     On 09/22/2015 06:25 PM, Alexandru Ardelean wrote:
>     > From: Alexandru Ardelean <aa@ocedo.com <mailto:aa@ocedo.com>>
>     >
>     > Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com
>     <mailto:ardeleanalex@gmail.com>>
>     > ---
>     >  target/linux/mpc85xx/Makefile | 5 ++++-
>     >  1 file changed, 4 insertions(+), 1 deletion(-)
>     >
>     > diff --git a/target/linux/mpc85xx/Makefile
>     b/target/linux/mpc85xx/Makefile
>     > index e43327a..bfc2c8d 100644
>     > --- a/target/linux/mpc85xx/Makefile
>     > +++ b/target/linux/mpc85xx/Makefile
>     > @@ -16,7 +16,10 @@ SUBTARGETS=generic p1020
>     >
>     >  KERNEL_PATCHVER:=3.18
>     >
>     > -KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
>     > +KERNEL_IMAGES := zImage
>     > +ifeq ($(CONFIG_TL_WDR4900_V1),y)
>     > +KERNEL_IMAGES += cuImage.tl-wdr4900-v1
>     > +endif
>     >
>     >  include $(INCLUDE_DIR)/target.mk <http://target.mk>
>     >
>     >
> 
>     This doesn't work, CONFIG_TL_WDR4900_V1 is a kernel .config option, not
>     a OpenWrt .config option, and thus isn't available in OpenWrt Makefiles.
>     What is this supposed to fix?
> 
> 
> Seems I'm confused here with the makefiles.
> 
> For our case, removing that kernel image file is needed, because we
> build our own mpc85xx image that is different from wdr4900-v1 ; so no
> file named cuImage.tl-wdr4900-v1.
> Ideally, I'd like to put it under a config option that disables/enables
> this ; I will admit that I haven't tried the case where this is on.
> 
> I'll try to find another option that disables this, that can also enable it.
> Any suggestions ?
Is this about non-upstream changes to the mpc85xx target? Or are you
using a different subtarget?
Either way, we should probably make the check for the 'generic' subtarget...

- Felix
Alexandru Ardelean Sept. 22, 2015, 1:56 p.m. UTC | #4
On Tue, Sep 22, 2015 at 4:45 PM, Felix Fietkau <nbd@openwrt.org> wrote:

> On 2015-09-22 15:11, Alexandru Ardelean wrote:
> >
> >
> > On Tue, Sep 22, 2015 at 4:05 PM, Matthias Schiffer
> > <mschiffer@universe-factory.net <mailto:mschiffer@universe-factory.net>>
> > wrote:
> >
> >     On 09/22/2015 06:25 PM, Alexandru Ardelean wrote:
> >     > From: Alexandru Ardelean <aa@ocedo.com <mailto:aa@ocedo.com>>
> >     >
> >     > Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com
> >     <mailto:ardeleanalex@gmail.com>>
> >     > ---
> >     >  target/linux/mpc85xx/Makefile | 5 ++++-
> >     >  1 file changed, 4 insertions(+), 1 deletion(-)
> >     >
> >     > diff --git a/target/linux/mpc85xx/Makefile
> >     b/target/linux/mpc85xx/Makefile
> >     > index e43327a..bfc2c8d 100644
> >     > --- a/target/linux/mpc85xx/Makefile
> >     > +++ b/target/linux/mpc85xx/Makefile
> >     > @@ -16,7 +16,10 @@ SUBTARGETS=generic p1020
> >     >
> >     >  KERNEL_PATCHVER:=3.18
> >     >
> >     > -KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
> >     > +KERNEL_IMAGES := zImage
> >     > +ifeq ($(CONFIG_TL_WDR4900_V1),y)
> >     > +KERNEL_IMAGES += cuImage.tl-wdr4900-v1
> >     > +endif
> >     >
> >     >  include $(INCLUDE_DIR)/target.mk <http://target.mk>
> >     >
> >     >
> >
> >     This doesn't work, CONFIG_TL_WDR4900_V1 is a kernel .config option,
> not
> >     a OpenWrt .config option, and thus isn't available in OpenWrt
> Makefiles.
> >     What is this supposed to fix?
> >
> >
> > Seems I'm confused here with the makefiles.
> >
> > For our case, removing that kernel image file is needed, because we
> > build our own mpc85xx image that is different from wdr4900-v1 ; so no
> > file named cuImage.tl-wdr4900-v1.
> > Ideally, I'd like to put it under a config option that disables/enables
> > this ; I will admit that I haven't tried the case where this is on.
> >
> > I'll try to find another option that disables this, that can also enable
> it.
> > Any suggestions ?
> Is this about non-upstream changes to the mpc85xx target? Or are you
> using a different subtarget?
> Either way, we should probably make the check for the 'generic'
> subtarget...
>
> - Felix
>

We use a different subtarget, and we're trying to find a solution for this
that is also upstream-able, in the idea that it makes sync-ing with
upstream easier.
Checking for the Generic subtarget sounds good.

Should I send a patch for that ?
Felix Fietkau Sept. 22, 2015, 1:57 p.m. UTC | #5
On 2015-09-22 15:56, Alexandru Ardelean wrote:
> We use a different subtarget, and we're trying to find a solution for
> this that is also upstream-able, in the idea that it makes sync-ing with
> upstream easier.
> Checking for the Generic subtarget sounds good.
> 
> Should I send a patch for that ?
Yes.

- Felix
diff mbox

Patch

diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index e43327a..bfc2c8d 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -16,7 +16,10 @@  SUBTARGETS=generic p1020
 
 KERNEL_PATCHVER:=3.18
 
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+KERNEL_IMAGES := zImage
+ifeq ($(CONFIG_TL_WDR4900_V1),y)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
 
 include $(INCLUDE_DIR)/target.mk