diff mbox

[OpenWrt-Devel,2/2] packages: Remove dependencies to kmod-ipv6

Message ID 1442739289-400-1-git-send-email-arjen+openwrt@de-korte.org
State Rejected
Headers show

Commit Message

Arjen de Korte Sept. 20, 2015, 8:54 a.m. UTC
Since r46834, IPv6 support is builtin if selected. Therefor, dependencies
on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore.

Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org>
---
 ipv6/tayga/Makefile         | 2 +-
 libs/libwebsockets/Makefile | 2 +-
 net/lispmob/Makefile        | 2 +-
 net/openvswitch/Makefile    | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

Comments

John Crispin Oct. 5, 2015, 10:22 a.m. UTC | #1
Hi,

On 20/09/2015 10:54, Arjen de Korte wrote:
> Since r46834, IPv6 support is builtin if selected. Therefor, dependencies
> on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore.
> 
> Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org>
> ---
>  ipv6/tayga/Makefile         | 2 +-
>  libs/libwebsockets/Makefile | 2 +-
>  net/lispmob/Makefile        | 2 +-
>  net/openvswitch/Makefile    | 2 +-
>  

these are all in the feed. please send a PR via github if you have not
done so already

	John



4 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/ipv6/tayga/Makefile b/ipv6/tayga/Makefile
> index ba0d196..d68a271 100644
> --- a/ipv6/tayga/Makefile
> +++ b/ipv6/tayga/Makefile
> @@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
>  define Package/tayga
>    SECTION:=net
>    CATEGORY:=Network
> -  DEPENDS:=+ip +kmod-ipv6 +kmod-tun
> +  DEPENDS:=+ip @IPV6 +kmod-tun
>    TITLE:=Out-of-kernel stateless NAT64 implementation for Linux
>    URL:=http://www.litech.org/tayga/
>    MAINTAINER:=Ondrej Caletka <ondrej@caletka.cz>
> diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
> index d9952e6..9e827d7 100644
> --- a/libs/libwebsockets/Makefile
> +++ b/libs/libwebsockets/Makefile
> @@ -27,7 +27,7 @@ CMAKE_INSTALL:=1
>  include $(INCLUDE_DIR)/package.mk
>  include $(INCLUDE_DIR)/cmake.mk
>  
> -CMAKE_OPTIONS += $(if $(CONFIG_PACKAGE_kmod-ipv6),,-DLWS_IPV6=)
> +CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DLWS_IPV6=)
>  
>  CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON
>  
> diff --git a/net/lispmob/Makefile b/net/lispmob/Makefile
> index 4742dee..3f9ea0c 100644
> --- a/net/lispmob/Makefile
> +++ b/net/lispmob/Makefile
> @@ -33,7 +33,7 @@ define Package/lispd
>    CATEGORY:=Network
>    TITLE:=Locator/ID separation protocol (using TUN)
>    URL:=https://github.com/LISPmob
> -  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
> +  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci @IPV6
>    $(call Package/lispd/default)
>  endef
>  
> diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
> index 86e6c52..903fdac 100644
> --- a/net/openvswitch/Makefile
> +++ b/net/openvswitch/Makefile
> @@ -98,7 +98,7 @@ define KernelPackage/openvswitch
>    SUBMENU:=Network Support
>    TITLE:=Open vSwitch Kernel Package
>    KCONFIG:=CONFIG_BRIDGE
> -  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
> +  DEPENDS:=+kmod-stp @IPV6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
>    FILES:= \
>  	$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
>    AUTOLOAD:=$(call AutoLoad,21,openvswitch)
>
Arjen de Korte Oct. 5, 2015, 10:44 a.m. UTC | #2
Citeren John Crispin <blogic@openwrt.org>:

> Hi,
>
> On 20/09/2015 10:54, Arjen de Korte wrote:
>> Since r46834, IPv6 support is builtin if selected. Therefor, dependencies
>> on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore.
>>
>> Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org>
>> ---
>>  ipv6/tayga/Makefile         | 2 +-
>>  libs/libwebsockets/Makefile | 2 +-
>>  net/lispmob/Makefile        | 2 +-
>>  net/openvswitch/Makefile    | 2 +-
>>
>
> these are all in the feed. please send a PR via github if you have not
> done so already

I don't even have an account on github, so no, this hasn't been done  
already. Guess I'll be on a steep learning curve to get this fixed.  
I'll look into fixing this through github later today.

Arjen

> 4 files changed, 4 insertions(+), 4 deletions(-)
>>
>> diff --git a/ipv6/tayga/Makefile b/ipv6/tayga/Makefile
>> index ba0d196..d68a271 100644
>> --- a/ipv6/tayga/Makefile
>> +++ b/ipv6/tayga/Makefile
>> @@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
>>  define Package/tayga
>>    SECTION:=net
>>    CATEGORY:=Network
>> -  DEPENDS:=+ip +kmod-ipv6 +kmod-tun
>> +  DEPENDS:=+ip @IPV6 +kmod-tun
>>    TITLE:=Out-of-kernel stateless NAT64 implementation for Linux
>>    URL:=http://www.litech.org/tayga/
>>    MAINTAINER:=Ondrej Caletka <ondrej@caletka.cz>
>> diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
>> index d9952e6..9e827d7 100644
>> --- a/libs/libwebsockets/Makefile
>> +++ b/libs/libwebsockets/Makefile
>> @@ -27,7 +27,7 @@ CMAKE_INSTALL:=1
>>  include $(INCLUDE_DIR)/package.mk
>>  include $(INCLUDE_DIR)/cmake.mk
>>
>> -CMAKE_OPTIONS += $(if $(CONFIG_PACKAGE_kmod-ipv6),,-DLWS_IPV6=)
>> +CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DLWS_IPV6=)
>>
>>  CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON
>>
>> diff --git a/net/lispmob/Makefile b/net/lispmob/Makefile
>> index 4742dee..3f9ea0c 100644
>> --- a/net/lispmob/Makefile
>> +++ b/net/lispmob/Makefile
>> @@ -33,7 +33,7 @@ define Package/lispd
>>    CATEGORY:=Network
>>    TITLE:=Locator/ID separation protocol (using TUN)
>>    URL:=https://github.com/LISPmob
>> -  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
>> +  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci @IPV6
>>    $(call Package/lispd/default)
>>  endef
>>
>> diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
>> index 86e6c52..903fdac 100644
>> --- a/net/openvswitch/Makefile
>> +++ b/net/openvswitch/Makefile
>> @@ -98,7 +98,7 @@ define KernelPackage/openvswitch
>>    SUBMENU:=Network Support
>>    TITLE:=Open vSwitch Kernel Package
>>    KCONFIG:=CONFIG_BRIDGE
>> -  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c  
>> +kmod-vxlan @($(SUPPORTED_KERNELS))
>> +  DEPENDS:=+kmod-stp @IPV6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan  
>> @($(SUPPORTED_KERNELS))
>>    FILES:= \
>>  	$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
>>    AUTOLOAD:=$(call AutoLoad,21,openvswitch)
>>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
diff mbox

Patch

diff --git a/ipv6/tayga/Makefile b/ipv6/tayga/Makefile
index ba0d196..d68a271 100644
--- a/ipv6/tayga/Makefile
+++ b/ipv6/tayga/Makefile
@@ -19,7 +19,7 @@  include $(INCLUDE_DIR)/package.mk
 define Package/tayga
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+ip +kmod-ipv6 +kmod-tun
+  DEPENDS:=+ip @IPV6 +kmod-tun
   TITLE:=Out-of-kernel stateless NAT64 implementation for Linux
   URL:=http://www.litech.org/tayga/
   MAINTAINER:=Ondrej Caletka <ondrej@caletka.cz>
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index d9952e6..9e827d7 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -27,7 +27,7 @@  CMAKE_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-CMAKE_OPTIONS += $(if $(CONFIG_PACKAGE_kmod-ipv6),,-DLWS_IPV6=)
+CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DLWS_IPV6=)
 
 CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON
 
diff --git a/net/lispmob/Makefile b/net/lispmob/Makefile
index 4742dee..3f9ea0c 100644
--- a/net/lispmob/Makefile
+++ b/net/lispmob/Makefile
@@ -33,7 +33,7 @@  define Package/lispd
   CATEGORY:=Network
   TITLE:=Locator/ID separation protocol (using TUN)
   URL:=https://github.com/LISPmob
-  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
+  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci @IPV6
   $(call Package/lispd/default)
 endef
 
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 86e6c52..903fdac 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -98,7 +98,7 @@  define KernelPackage/openvswitch
   SUBMENU:=Network Support
   TITLE:=Open vSwitch Kernel Package
   KCONFIG:=CONFIG_BRIDGE
-  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
+  DEPENDS:=+kmod-stp @IPV6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
   FILES:= \
 	$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,openvswitch)