diff mbox

[OpenWrt-Devel,3/4] Search for libjson along with libjson-c

Message ID 1441782592-25267-3-git-send-email-dbachtin@init-ka.de
State Changes Requested
Headers show

Commit Message

Bachtin, Dmitri Sept. 9, 2015, 7:23 a.m. UTC
Signed-off-by: Dmitri Bachtin <dbachtin@init-ka.de>
---
 CMakeLists.txt |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Comments

Felix Fietkau Sept. 9, 2015, 8:17 a.m. UTC | #1
On 2015-09-09 09:23, Bachtin, Dmitri wrote:
> Signed-off-by: Dmitri Bachtin <dbachtin@init-ka.de>
Which libjson is this? The old version of json-c?

- Felix
Felix Fietkau Sept. 9, 2015, 9:23 a.m. UTC | #2
On 2015-09-09 09:23, Bachtin, Dmitri wrote:
> Signed-off-by: Dmitri Bachtin <dbachtin@init-ka.de>
This patch probably require further checks. Please take a look at commit
cbf80de7f4df61960f386cb01a899cf4228d38f3 for more information.

- Felix
Bachtin, Dmitri Sept. 9, 2015, 9:46 a.m. UTC | #3
> This patch probably require further checks. Please take a look at commit
> cbf80de7f4df61960f386cb01a899cf4228d38f3 for more information.

> - Felix

I see. That makes sense. 

Please ignore then the patches 3 + 4 and the uqmi patch in the next thread. I think that they are better suited for distro-specific patches handled by a maintainer.

Thank you for reviewing the changes so quickly!

Sincerely,
 -- Dmitri Bachtin
diff mbox

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65819c3..ecb1508 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@  OPTION(BUILD_LUA "build Lua plugin" ON)
 OPTION(BUILD_EXAMPLES "build examples" ON)
 
 INCLUDE(FindPkgConfig)
-PKG_SEARCH_MODULE(JSONC json-c)
+PKG_SEARCH_MODULE(JSONC json-c json)
 IF(JSONC_FOUND)
   ADD_DEFINITIONS(-DJSONC)
   INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})
@@ -42,7 +42,7 @@  INSTALL(TARGETS ubox ubox-static
 ADD_SUBDIRECTORY(lua)
 ADD_SUBDIRECTORY(examples)
 
-find_library(json NAMES json-c)
+find_library(json NAMES json-c json)
 IF(EXISTS ${json})
 	ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
 	TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})