diff mbox

[OpenWrt-Devel,1/4] Build static version of libblobmsg_json

Message ID 1441782592-25267-1-git-send-email-dbachtin@init-ka.de
State Accepted
Headers show

Commit Message

Bachtin, Dmitri Sept. 9, 2015, 7:23 a.m. UTC
Signed-off-by: Dmitri Bachtin <dbachtin@init-ka.de>
---
 CMakeLists.txt |    7 ++++++-
 1 files changed, 6 insertions(+), 1 deletions(-)

Comments

Felix Fietkau Sept. 9, 2015, 8:16 a.m. UTC | #1
On 2015-09-09 09:23, Bachtin, Dmitri wrote:
> Signed-off-by: Dmitri Bachtin <dbachtin@init-ka.de>
Why?
Bachtin, Dmitri Sept. 9, 2015, 8:57 a.m. UTC | #2
> Why?

A libblobmsg_json.a would follow the same rule as with libubox.a already present in the CMakeLists.txt and allows consistent -dev packages I'd like to maintain for Debian in the future.

The reason is that Debian's Squeeze (oldstable) is still supported until Feb 2016. While it isn't a long time frame anymore, it will still be consistent to support all currently available versions if it is possible directly.

Greetings,
 -- Dmitri Bachtin
diff mbox

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecca3e9..65819c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,13 +47,18 @@  IF(EXISTS ${json})
 	ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
 	TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
 
+	ADD_LIBRARY(blobmsg_json-static STATIC blobmsg_json.c)
+	SET_TARGET_PROPERTIES(	blobmsg_json-static
+				PROPERTIES OUTPUT_NAME blobmsg_json)
+
 	ADD_EXECUTABLE(jshn jshn.c)
 	TARGET_LINK_LIBRARIES(jshn blobmsg_json ${json})
 
 	ADD_LIBRARY(json_script SHARED json_script.c)
 	TARGET_LINK_LIBRARIES(json_script ubox)
 
-	INSTALL(TARGETS blobmsg_json jshn json_script
+	INSTALL(TARGETS blobmsg_json blobmsg_json-static jshn json_script
+		ARCHIVE DESTINATION lib
 		LIBRARY DESTINATION lib
 		RUNTIME DESTINATION bin
 	)