diff mbox

[OpenWrt-Devel] ramips: Added WIZnet WizFi630A Platform based on Ralink RT5350

Message ID 1440697155-1021-1-git-send-email-tw@wiznet.eu
State Superseded
Headers show

Commit Message

Tobias Welz Aug. 27, 2015, 5:39 p.m. UTC
This patch is to add the WIZnet WizFi630A board as a new platform. 

Signed-off-by: Tobias Welz <tw@wiznet.eu>
---
 .../linux/ramips/base-files/etc/board.d/02_network |   10 ++
 target/linux/ramips/base-files/etc/diag.sh         |    3 +
 target/linux/ramips/base-files/lib/ramips.sh       |    3 +
 .../ramips/base-files/lib/upgrade/platform.sh      |    1 +
 target/linux/ramips/dts/WIZFI630A.dts              |  176 ++++++++++++++++++++
 target/linux/ramips/image/Makefile                 |    4 +-
 target/linux/ramips/rt305x/profiles/wiznet.mk      |   17 ++
 7 files changed, 213 insertions(+), 1 deletion(-)
 create mode 100644 target/linux/ramips/dts/WIZFI630A.dts
 create mode 100644 target/linux/ramips/rt305x/profiles/wiznet.mk

Comments

Piotr Dymacz Aug. 28, 2015, 11:04 a.m. UTC | #1
Hello Tobias,

Thanks for all fixes, but I'm afraid that there are still some
problems with new version of your patch (only cosmetic).
Please, see my (this time just a few) comments inline, below.

Cheers,
Piotr

2015-08-27 19:39 GMT+02:00 Tobias Welz <tw@wiznet.eu>:
> This patch is to add the WIZnet WizFi630A board as a new platform.
>
> Signed-off-by: Tobias Welz <tw@wiznet.eu>
> ---
>  .../linux/ramips/base-files/etc/board.d/02_network |   10 ++
>  target/linux/ramips/base-files/etc/diag.sh         |    3 +
>  target/linux/ramips/base-files/lib/ramips.sh       |    3 +
>  .../ramips/base-files/lib/upgrade/platform.sh      |    1 +
>  target/linux/ramips/dts/WIZFI630A.dts              |  176 ++++++++++++++++++++
>  target/linux/ramips/image/Makefile                 |    4 +-
>  target/linux/ramips/rt305x/profiles/wiznet.mk      |   17 ++
>  7 files changed, 213 insertions(+), 1 deletion(-)
>  create mode 100644 target/linux/ramips/dts/WIZFI630A.dts
>  create mode 100644 target/linux/ramips/rt305x/profiles/wiznet.mk
>
> diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
> index 6a2f042248d3..20f3367ac329 100755
> --- a/target/linux/ramips/base-files/etc/board.d/02_network
> +++ b/target/linux/ramips/base-files/etc/board.d/02_network
> @@ -217,6 +217,12 @@ ramips_setup_interfaces()
>                 ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
>                 ucidef_add_switch_vlan "switch0" "2" "5 6t"
>                 ;;
> +       wizfi630a)
> +               ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
> +               ucidef_add_switch "switch0" "1" "1"
> +               ucidef_add_switch_vlan "switch0" "1" "1 2 6t"
> +               ucidef_add_switch_vlan "switch0" "2" "0 6t"
> +               ;;
>         y1s)
>                 ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
>                 ucidef_add_switch "switch0" "1" "1"
> @@ -327,6 +333,10 @@ ramips_setup_macs()
>                 wan_mac=$(mtd_get_mac_binary factory 4)
>                 lan_mac=$wan_mac
>                 ;;
> +       wizfi630a)
> +               lan_mac=$(mtd_get_mac_binary factory 4)
> +               wan_mac=$(mtd_get_mac_binary factory 40)
> +               ;;
>         wsr-1166)
>                 local index="$(find_mtd_index "board_data")"
>                 wan_mac="$(grep -m1 mac= "/dev/mtd${index}" | cut -d= -f2)"
> diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
> index a4911b023cba..dfa0d02371ef 100644
> --- a/target/linux/ramips/base-files/etc/diag.sh
> +++ b/target/linux/ramips/base-files/etc/diag.sh
> @@ -165,6 +165,9 @@ get_status_led() {
>         wzr-agl300nh)
>                 status_led="$board:green:router"
>                 ;;
> +       wizfi630a)
> +               status_led="$board::run"
> +               ;;
>         wsr-1166|\
>         wsr-600)
>                 status_led="$board:orange:diag"
> diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
> index 5cafd4593d60..7cdf22512afa 100755
> --- a/target/linux/ramips/base-files/lib/ramips.sh
> +++ b/target/linux/ramips/base-files/lib/ramips.sh
> @@ -367,6 +367,9 @@ ramips_board_detect() {
>         *"WIZARD 8800")
>                 name="wizard8800"
>                 ;;
> +       *"WizFi630A")
> +               name="wizfi630a"
> +               ;;

Last line here has trailing white spaces.

Please, take a look at this small git grep command:
https://www.snip2code.com/Snippet/2032/Git-grep-for-trailing-whitespace

>         *"WL-330N")
>                 name="wl-330n"
>                 ;;
> diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
> index 53e7070c99c9..b907faa57885 100755
> --- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
> +++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
> @@ -107,6 +107,7 @@ platform_check_image() {
>         whr-300hp2|\
>         whr-600d|\
>         whr-g300n|\
> +       wizfi630a|\
>         wl-330n|\
>         wl-330n3g|\
>         wl-341v3|\
> diff --git a/target/linux/ramips/dts/WIZFI630A.dts b/target/linux/ramips/dts/WIZFI630A.dts
> new file mode 100644
> index 000000000000..545a7730af7d
> --- /dev/null
> +++ b/target/linux/ramips/dts/WIZFI630A.dts
> @@ -0,0 +1,176 @@
> +/dts-v1/;
> +
> +/include/ "rt5350.dtsi"
> +
> +/ {
> +       compatible = "wizfi630a", "ralink,rt5350-soc";
> +       model = "WIZnet WizFi630A";
> +
> +       chosen {
> +               bootargs = "console=ttyS1,115200";
> +       };
> +
> +       palmbus@10000000 {
> +               gpio1: gpio@660 {
> +                       status = "okay";
> +               };
> +
> +               spi@b00 {
> +                       status = "okay";
> +
> +                       m25p80@0 {
> +                               #address-cells = <1>;
> +                               #size-cells = <1>;
> +                               compatible = "w25q128";
> +                               reg = <0>;
> +                               linux,modalias = "m25p80", "w25q128";
> +                               spi-max-frequency = <10000000>;
> +
> +                               partition@0 {
> +                                       label = "uboot";
> +                                       reg = <0x0 0x30000>;
> +                                       read-only;
> +                               };
> +
> +                               partition@30000 {
> +                                       label = "uboot-env";
> +                                       reg = <0x30000 0x10000>;
> +                                       read-only;
> +                               };
> +
> +                               factory: partition@40000 {
> +                                       label = "factory";
> +                                       reg = <0x40000 0x10000>;
> +                                       read-only;
> +                               };
> +
> +                               partition@50000 {
> +                                       label = "firmware";
> +                                       reg = <0x50000 0xfb0000>;
> +                               };
> +                       };
> +               };
> +
> +               uart@500 {
> +                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
> +                       reg = <0x500 0x100>;
> +                       resets = <&rstctrl 12>;
> +                       reset-names = "uart";
> +                       interrupt-parent = <&intc>;
> +                       interrupts = <5>;
> +                       reg-shift = <2>;
> +                       status = "okay";
> +               };
> +
> +               uartlite@c00 {
> +                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
> +                       reg = <0xc00 0x100>;
> +                       resets = <&rstctrl 19>;
> +                       reset-names = "uartl";
> +                       interrupt-parent = <&intc>;
> +                       interrupts = <12>;
> +                       reg-shift = <2>;
> +                       pinctrl-names = "default";
> +                       pinctrl-0 = <&uartlite_pins>;
> +               };
> +       };
> +
> +       pinctrl {
> +               state_default: pinctrl0 {
> +                       gpio {
> +                               ralink,group = "i2c", "jtag" ;
> +                               ralink,function = "gpio";
> +                       };
> +               };
> +
> +               uartf_gpio_pins: uartf_gpio {
> +                       uartf_gpio {
> +                               ralink,group = "uartf";
> +                               ralink,function = "uartf";
> +                       };
> +               };
> +
> +               uartlite_pins: uartlite {
> +                       uart {
> +                               ralink,group = "uartlite";
> +                               ralink,function = "uartlite";
> +                       };
> +               };
> +       };
> +
> +       ethernet@10100000 {
> +               mtd-mac-address = <&factory 0x4>;
> +       };
> +
> +       esw@10110000 {
> +               ralink,portmap = <0x17>;
> +       };
> +
> +       wmac@10180000 {
> +               ralink,mtd-eeprom = <&factory 0>;
> +       };
> +
> +       ehci@101c0000 {
> +               status = "okay";
> +       };
> +
> +       ohci@101c1000 {
> +               status = "okay";
> +       };
> +
> +       gpio-export {
> +               compatible = "gpio-export";
> +               #size-cells = <0>;
> +       };
> +
> +       gpio-leds {
> +               compatible = "gpio-leds";

New line here, please.

> +               run {
> +                       label = "wizfi630a::run";
> +                       gpios = <&gpio0 1 1>;
> +               };

New line here, please.

> +               uart1 {
> +                       label = "wizfi630a::uart1";
> +                       gpios = <&gpio0 18 1>;
> +               };

New line here, please.

> +               uart2 {
> +                       label = "wizfi630a::uart2";
> +                       gpios = <&gpio0 21 1>;
> +               };

New line here, please.

> +               wps {
> +                       label = "wizfi630a::wps";
> +                       gpios = <&gpio0 20 1>;
> +               };
> +       };
> +
> +       gpio-keys-polled {
> +               compatible = "gpio-keys-polled";
> +               #address-cells = <1>;
> +               #size-cells = <0>;
> +               poll-interval = <20>;
> +
> +               reset {
> +                       label = "reset";
> +                       gpios = <&gpio0 17 1>;
> +                       linux,code = <0x198>;
> +               };
> +
> +               wps {
> +                       label = "wps";
> +                       gpios = <&gpio0 0 1>;
> +                       linux,code = <0x211>;
> +               };
> +
> +               scm1 {
> +                       label = "SCM1";
> +                       gpios = <&gpio0 19 1>;
> +                       linux,code = <0x100>;
> +               };
> +
> +               scm2 {
> +                       label = "SCM2";
> +                       gpios = <&gpio0 2 1>;
> +                       linux,code = <0x101>;
> +               };
> +       };
> +};
> diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
> index 2f4d4cbc617d..ac2e83cbb3de 100644
> --- a/target/linux/ramips/image/Makefile
> +++ b/target/linux/ramips/image/Makefile
> @@ -608,7 +608,6 @@ Image/Build/Profile/W502U=$(call BuildFirmware/Default8M/$(1),$(1),w502u,W502U)
>
>  Image/Build/Profile/WCR150GN=$(call BuildFirmware/Default4M/$(1),$(1),wcr150gn,WCR150GN)
>
> -
>  Image/Build/Profile/MZK-DP150N=$(call BuildFirmware/Default4M/$(1),$(1),mzk-dp150n,MZK-DP150N)
>
>  buffalo_whrg300n_mtd_size=3801088
> @@ -631,6 +630,8 @@ Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
>
>  Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
>
> +Image/Build/Profile/WIZFI630A=$(call BuildFirmware/Default16M/$(1),$(1),wizfi630a,WIZFI630A)
> +
>  Image/Build/Profile/WL-330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL-330N)
>
>  Image/Build/Profile/WL-330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL-330N3G)
> @@ -763,6 +764,7 @@ define Image/Build/Profile/Default
>         $(call Image/Build/Profile/WCR150GN,$(1))
>         $(call Image/Build/Profile/WHRG300N,$(1))
>         $(call Image/Build/Profile/WIZARD8800,$(1))
> +       $(call Image/Build/Profile/WIZFI630A,$(1))
>         $(call Image/Build/Profile/WL-330N,$(1))
>         $(call Image/Build/Profile/WL-330N3G,$(1))
>         $(call Image/Build/Profile/WL-341V3,$(1))
> diff --git a/target/linux/ramips/rt305x/profiles/wiznet.mk b/target/linux/ramips/rt305x/profiles/wiznet.mk
> new file mode 100644
> index 000000000000..f8e83242898d
> --- /dev/null
> +++ b/target/linux/ramips/rt305x/profiles/wiznet.mk
> @@ -0,0 +1,17 @@
> +#
> +# Copyright (C) 2015 OpenWrt.org
> +#
> +# This is free software, licensed under the GNU General Public License v2.
> +# See /LICENSE for more information.
> +#
> +
> +define Profile/WIZFI630A
> +       NAME:=WIZnet WizFi630A
> +       PACKAGES:=\
> +               kmod-usb2
> +endef
> +
> +define Profile/WIZFI630A/Description
> +       Package set for WIZnet WizFi630A board
> +endef
> +$(eval $(call Profile,WIZFI630A))
> --
> 1.7.10.4
>
diff mbox

Patch

diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 6a2f042248d3..20f3367ac329 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -217,6 +217,12 @@  ramips_setup_interfaces()
 		ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
 		ucidef_add_switch_vlan "switch0" "2" "5 6t"
 		;;
+	wizfi630a)
+		ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+		ucidef_add_switch "switch0" "1" "1"
+		ucidef_add_switch_vlan "switch0" "1" "1 2 6t"
+		ucidef_add_switch_vlan "switch0" "2" "0 6t"
+		;;
 	y1s)
 		ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
 		ucidef_add_switch "switch0" "1" "1"
@@ -327,6 +333,10 @@  ramips_setup_macs()
 		wan_mac=$(mtd_get_mac_binary factory 4)
 		lan_mac=$wan_mac
 		;;
+	wizfi630a)
+		lan_mac=$(mtd_get_mac_binary factory 4)
+		wan_mac=$(mtd_get_mac_binary factory 40)
+		;;
 	wsr-1166)
 		local index="$(find_mtd_index "board_data")"
 		wan_mac="$(grep -m1 mac= "/dev/mtd${index}" | cut -d= -f2)"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index a4911b023cba..dfa0d02371ef 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -165,6 +165,9 @@  get_status_led() {
 	wzr-agl300nh)
 		status_led="$board:green:router"
 		;;
+	wizfi630a)
+		status_led="$board::run"
+		;;
 	wsr-1166|\
 	wsr-600)
 		status_led="$board:orange:diag"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 5cafd4593d60..7cdf22512afa 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -367,6 +367,9 @@  ramips_board_detect() {
 	*"WIZARD 8800")
 		name="wizard8800"
 		;;
+	*"WizFi630A")
+		name="wizfi630a"
+		;;                
 	*"WL-330N")
 		name="wl-330n"
 		;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 53e7070c99c9..b907faa57885 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -107,6 +107,7 @@  platform_check_image() {
 	whr-300hp2|\
 	whr-600d|\
 	whr-g300n|\
+	wizfi630a|\
 	wl-330n|\
 	wl-330n3g|\
 	wl-341v3|\
diff --git a/target/linux/ramips/dts/WIZFI630A.dts b/target/linux/ramips/dts/WIZFI630A.dts
new file mode 100644
index 000000000000..545a7730af7d
--- /dev/null
+++ b/target/linux/ramips/dts/WIZFI630A.dts
@@ -0,0 +1,176 @@ 
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+	compatible = "wizfi630a", "ralink,rt5350-soc";
+	model = "WIZnet WizFi630A";
+
+	chosen {
+		bootargs = "console=ttyS1,115200";
+	};
+
+	palmbus@10000000 {
+		gpio1: gpio@660 {
+			status = "okay";
+		};
+
+		spi@b00 {
+			status = "okay";
+
+			m25p80@0 {
+				#address-cells = <1>;
+				#size-cells = <1>;
+				compatible = "w25q128";
+				reg = <0>;
+				linux,modalias = "m25p80", "w25q128";
+				spi-max-frequency = <10000000>;
+
+				partition@0 {
+					label = "uboot";
+					reg = <0x0 0x30000>;
+					read-only;
+				};
+
+				partition@30000 {
+					label = "uboot-env";
+					reg = <0x30000 0x10000>;
+					read-only;
+				};
+
+				factory: partition@40000 {
+					label = "factory";
+					reg = <0x40000 0x10000>;
+					read-only;
+				};
+
+				partition@50000 {
+					label = "firmware";
+					reg = <0x50000 0xfb0000>;
+				};
+			};
+		};
+
+		uart@500 {
+			compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+			reg = <0x500 0x100>;
+			resets = <&rstctrl 12>;
+			reset-names = "uart";
+			interrupt-parent = <&intc>;
+			interrupts = <5>;
+			reg-shift = <2>;
+			status = "okay";
+		};
+
+		uartlite@c00 {
+			compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+			reg = <0xc00 0x100>;
+			resets = <&rstctrl 19>;
+			reset-names = "uartl";
+			interrupt-parent = <&intc>;
+			interrupts = <12>;
+			reg-shift = <2>;
+			pinctrl-names = "default";
+			pinctrl-0 = <&uartlite_pins>;
+		};
+	};
+
+	pinctrl {
+		state_default: pinctrl0 {
+			gpio {
+				ralink,group = "i2c", "jtag" ;
+				ralink,function = "gpio";
+			};
+		};
+
+		uartf_gpio_pins: uartf_gpio {
+			uartf_gpio {
+				ralink,group = "uartf";
+				ralink,function = "uartf";
+			};
+		};
+
+		uartlite_pins: uartlite {
+			uart {
+				ralink,group = "uartlite";
+				ralink,function = "uartlite";
+			};
+		};
+	};
+
+	ethernet@10100000 {
+		mtd-mac-address = <&factory 0x4>;
+	};
+
+	esw@10110000 {
+		ralink,portmap = <0x17>;
+	};
+
+	wmac@10180000 {
+		ralink,mtd-eeprom = <&factory 0>;
+	};
+
+	ehci@101c0000 {
+		status = "okay";
+	};
+
+	ohci@101c1000 {
+		status = "okay";
+	};
+
+	gpio-export {
+		compatible = "gpio-export";
+		#size-cells = <0>;
+	};
+
+	gpio-leds {
+		compatible = "gpio-leds";
+		run {
+			label = "wizfi630a::run";
+			gpios = <&gpio0 1 1>;
+		};
+		uart1 {
+			label = "wizfi630a::uart1";
+			gpios = <&gpio0 18 1>;
+		};
+		uart2 {
+			label = "wizfi630a::uart2";
+			gpios = <&gpio0 21 1>;
+		};
+		wps {
+			label = "wizfi630a::wps";
+			gpios = <&gpio0 20 1>;
+		};
+	};
+
+	gpio-keys-polled {
+		compatible = "gpio-keys-polled";
+		#address-cells = <1>;
+		#size-cells = <0>;
+		poll-interval = <20>;
+
+		reset {
+			label = "reset";
+			gpios = <&gpio0 17 1>;
+			linux,code = <0x198>;
+		};
+
+		wps {
+			label = "wps";
+			gpios = <&gpio0 0 1>;
+			linux,code = <0x211>;
+		};
+		
+		scm1 {
+			label = "SCM1";
+			gpios = <&gpio0 19 1>;
+			linux,code = <0x100>;
+		};
+
+		scm2 {
+			label = "SCM2";
+			gpios = <&gpio0 2 1>;
+			linux,code = <0x101>;
+		};
+	};
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2f4d4cbc617d..ac2e83cbb3de 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -608,7 +608,6 @@  Image/Build/Profile/W502U=$(call BuildFirmware/Default8M/$(1),$(1),w502u,W502U)
 
 Image/Build/Profile/WCR150GN=$(call BuildFirmware/Default4M/$(1),$(1),wcr150gn,WCR150GN)
 
-
 Image/Build/Profile/MZK-DP150N=$(call BuildFirmware/Default4M/$(1),$(1),mzk-dp150n,MZK-DP150N)
 
 buffalo_whrg300n_mtd_size=3801088
@@ -631,6 +630,8 @@  Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
 Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
 
+Image/Build/Profile/WIZFI630A=$(call BuildFirmware/Default16M/$(1),$(1),wizfi630a,WIZFI630A)
+
 Image/Build/Profile/WL-330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL-330N)
 
 Image/Build/Profile/WL-330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL-330N3G)
@@ -763,6 +764,7 @@  define Image/Build/Profile/Default
 	$(call Image/Build/Profile/WCR150GN,$(1))
 	$(call Image/Build/Profile/WHRG300N,$(1))
 	$(call Image/Build/Profile/WIZARD8800,$(1))
+	$(call Image/Build/Profile/WIZFI630A,$(1))
 	$(call Image/Build/Profile/WL-330N,$(1))
 	$(call Image/Build/Profile/WL-330N3G,$(1))
 	$(call Image/Build/Profile/WL-341V3,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/wiznet.mk b/target/linux/ramips/rt305x/profiles/wiznet.mk
new file mode 100644
index 000000000000..f8e83242898d
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/wiznet.mk
@@ -0,0 +1,17 @@ 
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WIZFI630A
+	NAME:=WIZnet WizFi630A
+	PACKAGES:=\
+		kmod-usb2 
+endef
+
+define Profile/WIZFI630A/Description
+	Package set for WIZnet WizFi630A board
+endef
+$(eval $(call Profile,WIZFI630A))