diff mbox

[OpenWrt-Devel,2/3] kernel: package up sdhci-pxav3

Message ID 1440337944-3803-2-git-send-email-jogo@openwrt.org
State Changes Requested
Headers show

Commit Message

Jonas Gorski Aug. 23, 2015, 1:52 p.m. UTC
Package the sdhci controller driver found on armada 38x boards and add
backported fixes to allow them to be selected / not break the boot.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
---
 package/kernel/linux/modules/other.mk              | 12 ++++++++
 ...Fix-hardware-dependencies-for-sdhci-pxav3.patch | 33 ++++++++++++++++++++++
 2 files changed, 45 insertions(+)
 create mode 100644 target/linux/mvebu/patches-4.0/060-mmc-Fix-hardware-dependencies-for-sdhci-pxav3.patch
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4a65a03..0da9a33 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -362,6 +362,18 @@  endef
 $(eval $(call KernelPackage,sdhci))
 
 
+define KernelPackage/sdhci-pxav3
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell MMP2 SD Host Controller support (PXAV3)
+  DEPENDS:=+kmod-sdhci @TARGET_mvebu
+  KCONFIG:=CONFIG_MMC_SDHCI_PXAV3
+  FILES:=$(LINUX_DIR)/drivers/mmc/host/sdhci-pxav3.ko
+  AUTOLOAD:=$(call AutoProbe,sdhci-pxav3,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-pxav3))
+
+
 define KernelPackage/oprofile
   SUBMENU:=$(OTHER_MENU)
   TITLE:=OProfile profiling support
diff --git a/target/linux/mvebu/patches-4.0/060-mmc-Fix-hardware-dependencies-for-sdhci-pxav3.patch b/target/linux/mvebu/patches-4.0/060-mmc-Fix-hardware-dependencies-for-sdhci-pxav3.patch
new file mode 100644
index 0000000..5cc08b5
--- /dev/null
+++ b/target/linux/mvebu/patches-4.0/060-mmc-Fix-hardware-dependencies-for-sdhci-pxav3.patch
@@ -0,0 +1,33 @@ 
+From daa3054f5772b14dd073a2b95fd0353faec0fcc5 Mon Sep 17 00:00:00 2001
+From: Jean Delvare <jdelvare@suse.de>
+Date: Mon, 23 Feb 2015 11:30:40 +0100
+Subject: [PATCH] mmc: Fix hardware dependencies for sdhci-pxav3
+
+It was brought to my attention that the sdhci-pxav3 driver is needed
+on a few more ARM machines than I initially thought. Add the missing
+architectures to the dependency list.
+
+Credits to Peter Robinson for noticing my mistake and reporting.
+
+Reported-by: Peter Robinson <pbrobinson@gmail.com>
+Signed-off-by: Jean Delvare <jdelvare@suse.de>
+Cc: Chris Ball <chris@printf.net>
+Cc: Ulf Hansson <ulf.hansson@linaro.org>
+Cc: Eric Miao <eric.y.miao@gmail.com>
+Cc: Haojian Zhuang <haojian.zhuang@gmail.com>
+Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
+---
+ drivers/mmc/host/Kconfig |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/drivers/mmc/host/Kconfig
++++ b/drivers/mmc/host/Kconfig
+@@ -230,7 +230,7 @@ config MMC_SDHCI_PXAV3
+ 	tristate "Marvell MMP2 SD Host Controller support (PXAV3)"
+ 	depends on CLKDEV_LOOKUP
+ 	depends on MMC_SDHCI_PLTFM
+-	depends on ARCH_MMP || COMPILE_TEST
++	depends on ARCH_BERLIN || ARCH_MMP || ARCH_MVEBU || COMPILE_TEST
+ 	default CPU_MMP2
+ 	help
+ 	  This selects the Marvell(R) PXAV3 SD Host Controller.