diff mbox

[OpenWrt-Devel,v2,3/3] mcs814x: use firmware partition splitter on dLAN USB Extender

Message ID 1437994095-16492-4-git-send-email-guenther.kelleter@devolo.de
State Superseded
Headers show

Commit Message

Günther Kelleter July 27, 2015, 10:48 a.m. UTC
Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de>
---
 target/linux/mcs814x/config-3.18                                  | 4 ++++
 .../mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts    | 8 --------
 target/linux/mcs814x/image/Makefile                               | 2 +-
 3 files changed, 5 insertions(+), 9 deletions(-)

Comments

Florian Fainelli July 27, 2015, 5:53 p.m. UTC | #1
On Jul 27, 2015 3:55 AM, "Günther Kelleter" <guenther.kelleter@devolo.de>
wrote:

Looks good to me, having a better commit message would be welcome.

>
> Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de>
> ---
>  target/linux/mcs814x/config-3.18                                  | 4
++++
>  .../mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts    | 8
--------
>  target/linux/mcs814x/image/Makefile                               | 2 +-
>  3 files changed, 5 insertions(+), 9 deletions(-)
>
> diff --git a/target/linux/mcs814x/config-3.18
b/target/linux/mcs814x/config-3.18
> index e57f5ff..427a7c9 100644
> --- a/target/linux/mcs814x/config-3.18
> +++ b/target/linux/mcs814x/config-3.18
> @@ -159,6 +159,10 @@ CONFIG_MODULES_USE_ELF_REL=y
>  # CONFIG_MTD_IMPA7 is not set
>  CONFIG_MTD_JEDECPROBE=y
>  CONFIG_MTD_PHYSMAP=y
> +# CONFIG_MTD_ROOTFS_SPLIT is not set
> +CONFIG_MTD_SPLIT_FIRMWARE=y
> +CONFIG_MTD_SPLIT_FIRMWARE_NAME="linux"
> +CONFIG_MTD_SPLIT_UIMAGE_FW=y
>  CONFIG_MULTI_IRQ_HANDLER=y
>  CONFIG_NEED_DMA_MAP_STATE=y
>  CONFIG_NEED_KUSER_HELPERS=y
> diff --git
a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
> index 0c85b94..59830e8 100644
> ---
a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
> +++
b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
> @@ -48,14 +48,6 @@
>                                                 reg = <0x40000 0x10000>;
>                                         };
>                                         partition@50000 {
> -                                               label = "kernel";
> -                                               reg = <0x50000 0x100000>;
> -                                       };
> -                                       partition@150000 {
> -                                               label = "rootfs";
> -                                               reg = <0x150000 0x3C0000>;
> -                                       };
> -                                       partition@50001 {
>                                                 label = "linux";
>                                                 reg = <0x50000 0x4C0000>;
>                                         };
> diff --git a/target/linux/mcs814x/image/Makefile
b/target/linux/mcs814x/image/Makefile
> index 4c8af97..74f8ad4 100644
> --- a/target/linux/mcs814x/image/Makefile
> +++ b/target/linux/mcs814x/image/Makefile
> @@ -30,7 +30,7 @@ define Image/Build/DTB
>  endef
>
>  define Image/Build/Profile/dLAN_USB_Extender
> -       dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync
of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
> +       dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync
of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
>         cat $(KDIR)/root.$(1) >>
$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
>         cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
$(BIN_DIR)/
>  endef
> --
> 2.4.6.89.g851dcf4
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
diff mbox

Patch

diff --git a/target/linux/mcs814x/config-3.18 b/target/linux/mcs814x/config-3.18
index e57f5ff..427a7c9 100644
--- a/target/linux/mcs814x/config-3.18
+++ b/target/linux/mcs814x/config-3.18
@@ -159,6 +159,10 @@  CONFIG_MODULES_USE_ELF_REL=y
 # CONFIG_MTD_IMPA7 is not set
 CONFIG_MTD_JEDECPROBE=y
 CONFIG_MTD_PHYSMAP=y
+# CONFIG_MTD_ROOTFS_SPLIT is not set
+CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_FIRMWARE_NAME="linux"
+CONFIG_MTD_SPLIT_UIMAGE_FW=y
 CONFIG_MULTI_IRQ_HANDLER=y
 CONFIG_NEED_DMA_MAP_STATE=y
 CONFIG_NEED_KUSER_HELPERS=y
diff --git a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
index 0c85b94..59830e8 100644
--- a/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
+++ b/target/linux/mcs814x/files-3.18/arch/arm/boot/dts/dlan-usb-extender.dts
@@ -48,14 +48,6 @@ 
 						reg = <0x40000 0x10000>;
 					};
 					partition@50000 {
-						label = "kernel";
-						reg = <0x50000 0x100000>;
-					};
-					partition@150000 {
-						label = "rootfs";
-						reg = <0x150000 0x3C0000>;
-					};
-					partition@50001 {
 						label = "linux";
 						reg = <0x50000 0x4C0000>;
 					};
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 4c8af97..74f8ad4 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -30,7 +30,7 @@  define Image/Build/DTB
 endef
 
 define Image/Build/Profile/dLAN_USB_Extender
-	dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
+	dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
 	cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
 	cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
 endef