diff mbox

[OpenWrt-Devel] perf: replace libelf1 select by a depend

Message ID 1432675095-7805-1-git-send-email-mathieu@codeaurora.org
State Rejected
Headers show

Commit Message

Mathieu Olivari May 26, 2015, 9:18 p.m. UTC
perf has libelf1 marked as a select, but this package is actually
located in packages.git. As such, the dependency is ignored unless
libelf1 package has been manually installed previously.

To avoid any missing dependency, we'll mark it as a regular depend.
This will make sure the dependency check doesn't silently fail.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
---
 package/devel/perf/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Luiz Angelo Daros de Luca May 26, 2015, 10:08 p.m. UTC | #1
Hi Mathieu,

So the elfutils import from packages.git was rejected?

Regards,

Luiz Angelo,

Em ter, 26 de mai de 2015 às 18:18, Mathieu Olivari <mathieu@codeaurora.org>
escreveu:

> perf has libelf1 marked as a select, but this package is actually
> located in packages.git. As such, the dependency is ignored unless
> libelf1 package has been manually installed previously.
>
> To avoid any missing dependency, we'll mark it as a regular depend.
> This will make sure the dependency check doesn't silently fail.
>
> Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
> ---
>  package/devel/perf/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
> index b77e29a..e31a693 100644
> --- a/package/devel/perf/Makefile
> +++ b/package/devel/perf/Makefile
> @@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
>  define Package/perf
>    SECTION:=devel
>    CATEGORY:=Development
> -  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
> +  DEPENDS:= libelf1 +libdw +libpthread +librt +binutils
>    TITLE:=Linux performance monitoring tool
>    VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
>    URL:=http://www.kernel.org
> --
> 2.1.4
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
diff mbox

Patch

diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index b77e29a..e31a693 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -19,7 +19,7 @@  include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= libelf1 +libdw +libpthread +librt +binutils
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org