diff mbox

[OpenWrt-Devel] ar71xx/image: remove duplicated rootfs in new tplink initramfs images

Message ID 1429040052-30339-1-git-send-email-lynxis@fe80.eu
State Accepted
Headers show

Commit Message

Alexander 'lynxis' Couzens April 14, 2015, 7:34 p.m. UTC
The new building code included the rootfs twice when building tplink initramfs images.
To make it more readable move initramfs into an own build step
Build/mktplinkfw-initramfs.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
---
 target/linux/ar71xx/image/Makefile | 18 ++++++++++++++----
 1 file changed, 14 insertions(+), 4 deletions(-)
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4819ab9..49c3ca0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -56,10 +56,20 @@  define Build/mktplinkfw
 		-k $(word 1,$^) \
 		-r $@ \
 		-o $@.new \
+		-j -X 0x40000 \
 		-a $(call rootfs_align,$(FILESYSTEM)) \
-		$(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
-		$(if $(findstring factory,$1),-j -X 0x40000) \
-		$(if $(findstring initramfs,$1),-s -c)
+		$(if $(findstring sysupgrade,$1),-s)
+	@mv $@.new $@
+endef
+
+# -c combined image
+define Build/mktplinkfw-initramfs
+	$(STAGING_DIR_HOST)/bin/mktplinkfw \
+		-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+		-k $@ \
+		-o $@.new \
+		-s \
+		-c
 	@mv $@.new $@
 endef
 
@@ -138,7 +148,7 @@  TARGET_DEVICES += wndr3700 wndr3700v2 wndr3800 wndr3800ch wndrmac wndrmacv2
 define Device/tplink
   TPLINK_HWREV := 0x1
   KERNEL := kernel-bin | patch-cmdline | lzma
-  KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw initramfs
+  KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw-initramfs
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
   IMAGE/factory.bin := append-rootfs | mktplinkfw factory