diff mbox

[OpenWrt-Devel,2/3] brcm2708: add Raspberry Pi 2 support

Message ID 1423654423-7672-2-git-send-email-noltari@gmail.com
State Accepted
Delegated to: John Crispin
Headers show

Commit Message

Álvaro Fernández Rojas Feb. 11, 2015, 11:33 a.m. UTC
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
---
 target/linux/brcm2708/Makefile                         |  4 ++--
 target/linux/brcm2708/bcm2708/config-default           |  3 +++
 target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk  | 16 ++++++++++++++++
 target/linux/brcm2708/bcm2708/target.mk                |  5 +++++
 target/linux/brcm2708/bcm2709/config-default           | 17 +++++++++++++++++
 target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk | 16 ++++++++++++++++
 target/linux/brcm2708/bcm2709/target.mk                |  7 +++++++
 target/linux/brcm2708/config-3.18                      |  5 +++--
 target/linux/brcm2708/profiles/100-RaspberryPi.mk      | 17 -----------------
 9 files changed, 69 insertions(+), 21 deletions(-)
 create mode 100644 target/linux/brcm2708/bcm2708/config-default
 create mode 100644 target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
 create mode 100644 target/linux/brcm2708/bcm2708/target.mk
 create mode 100644 target/linux/brcm2708/bcm2709/config-default
 create mode 100644 target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
 create mode 100644 target/linux/brcm2708/bcm2709/target.mk
 mode change 100755 => 100644 target/linux/brcm2708/config-3.18
 delete mode 100644 target/linux/brcm2708/profiles/100-RaspberryPi.mk

Comments

John Crispin Feb. 11, 2015, 11:36 a.m. UTC | #1
On 11/02/2015 12:33, Álvaro Fernández Rojas wrote:
> -BOARDNAME:=Broadcom BCM2708/BCM2835

should this not be

> +BOARDNAME:=Broadcom BCM2708/BCM2835/BCM2709

i think BCM2835 is used on one of the B+ variants

	John
Álvaro Fernández Rojas Feb. 11, 2015, 11:42 a.m. UTC | #2
From popcornmix: https://github.com/raspberrypi/linux/issues/22
Technically 2708 is the family, and 2835 is a specific implementation.
We now know that 2835 is the only implementation in the family that can run linux, (and there won't be new models of this family), so it probably doesn't matter which model is used, although it should be consistent.

If we wanted to use BCM2835, it would make sense also to use BCM2836.
So it would be BOARDNAME:=Broadcom BCM2708/BCM2835/BCM2709/BCM2836, which is kinda long :$.

I suggest either using BCM2708/BCM2709 or BCM2835/BCM2836, but using both seems weird, at least for me.

El 11/02/2015 a las 12:36, John Crispin escribió:
> 
> 
> On 11/02/2015 12:33, Álvaro Fernández Rojas wrote:
>> -BOARDNAME:=Broadcom BCM2708/BCM2835
> 
> should this not be
> 
>> +BOARDNAME:=Broadcom BCM2708/BCM2835/BCM2709
> 
> i think BCM2835 is used on one of the B+ variants
> 
> 	John
>
John Crispin Feb. 11, 2015, 11:55 a.m. UTC | #3
On 11/02/2015 12:42, Álvaro Fernández Rojas wrote:
> From popcornmix: https://github.com/raspberrypi/linux/issues/22 
> Technically 2708 is the family, and 2835 is a specific
> implementation. We now know that 2835 is the only implementation in
> the family that can run linux, (and there won't be new models of
> this family), so it probably doesn't matter which model is used,
> although it should be consistent.
> 

good to know

> If we wanted to use BCM2835, it would make sense also to use
> BCM2836. So it would be BOARDNAME:=Broadcom
> BCM2708/BCM2835/BCM2709/BCM2836, which is kinda long :$.
> 
> I suggest either using BCM2708/BCM2709 or BCM2835/BCM2836, but
> using both seems weird, at least for me.

patch looks fine in that case i am already building a test tree ;)
diff mbox

Patch

diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 6f515a5..3ba9ac8 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -9,7 +9,7 @@  include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
-BOARDNAME:=Broadcom BCM2708/BCM2835
+BOARDNAME:=Broadcom BCM2708/BCM2709
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
@@ -21,7 +21,7 @@  include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
 
 define Target/Description
-	Build firmware image for Broadcom BCM2708/BCM2835 SoC devices.
+	Build firmware image for Broadcom BCM2708/BCM2709 SoC devices.
 	Currently produces SD Card image for Raspberry Pi.
 endef
 
diff --git a/target/linux/brcm2708/bcm2708/config-default b/target/linux/brcm2708/bcm2708/config-default
new file mode 100644
index 0000000..8ebd8e8
--- /dev/null
+++ b/target/linux/brcm2708/bcm2708/config-default
@@ -0,0 +1,3 @@ 
+CONFIG_ARCH_BCM2708=y
+# CONFIG_BCM2708_DT is not set
+CONFIG_VMSPLIT_3G=y
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
new file mode 100644
index 0000000..94d0a06
--- /dev/null
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -0,0 +1,16 @@ 
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RaspberryPi
+  NAME:=Raspberry Pi
+endef
+
+define Profile/RaspberryPi/Description
+	Raspberry Pi board
+endef
+
+$(eval $(call Profile,RaspberryPi))
diff --git a/target/linux/brcm2708/bcm2708/target.mk b/target/linux/brcm2708/bcm2708/target.mk
new file mode 100644
index 0000000..a2004a6
--- /dev/null
+++ b/target/linux/brcm2708/bcm2708/target.mk
@@ -0,0 +1,5 @@ 
+BOARDNAME:=bcm2708
+
+define Target/Description
+	Build firmware image for Broadcom BCM2708 SoC devices.
+endef
diff --git a/target/linux/brcm2708/bcm2709/config-default b/target/linux/brcm2708/bcm2709/config-default
new file mode 100644
index 0000000..e9d87ca
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/config-default
@@ -0,0 +1,17 @@ 
+CONFIG_ARCH_BCM2709=y
+# CONFIG_ARM_LPAE is not set
+# CONFIG_ARM_THUMBEE is not set
+CONFIG_ARM_ARCH_TIMER_EVTSTREAM=y
+CONFIG_BCM2708_NOL2CACHE=y
+# CONFIG_BCM2709_DT is not set
+# CONFIG_CRYPTO_SHA1_ARM_NEON is not set
+# CONFIG_CRYPTO_SHA512_ARM_NEON is not set
+CONFIG_HAVE_ARM_ARCH_TIMER=y
+CONFIG_KERNEL_MODE_NEON=y
+CONFIG_LOCALVERSION="-v7"
+CONFIG_NEON=y
+CONFIG_NR_CPUS=4
+CONFIG_SMP=y
+CONFIG_SMP_ON_UP=y
+# CONFIG_THUMB2_KERNEL is not set
+CONFIG_VMSPLIT_2G=y
diff --git a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
new file mode 100644
index 0000000..d3d1617
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
@@ -0,0 +1,16 @@ 
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RaspberryPi2
+  NAME:=Raspberry Pi 2
+endef
+
+define Profile/RaspberryPi2/Description
+	Raspberry Pi 2 board
+endef
+
+$(eval $(call Profile,RaspberryPi2))
diff --git a/target/linux/brcm2708/bcm2709/target.mk b/target/linux/brcm2708/bcm2709/target.mk
new file mode 100644
index 0000000..610c6b0
--- /dev/null
+++ b/target/linux/brcm2708/bcm2709/target.mk
@@ -0,0 +1,7 @@ 
+BOARDNAME:=bcm2709
+CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=vfp
+
+define Target/Description
+	Build firmware image for Broadcom BCM2709 SoC devices.
+endef
diff --git a/target/linux/brcm2708/config-3.18 b/target/linux/brcm2708/config-3.18
old mode 100755
new mode 100644
index 36bd97f..7765d13
--- a/target/linux/brcm2708/config-3.18
+++ b/target/linux/brcm2708/config-3.18
@@ -2,7 +2,7 @@ 
 CONFIG_ALIGNMENT_TRAP=y
 # CONFIG_AMBA_PL08X is not set
 # CONFIG_APM_EMULATION is not set
-CONFIG_ARCH_BCM2708=y
+# CONFIG_ARCH_BCM2708 is not set
 # CONFIG_ARCH_BCM2709 is not set
 CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y
 CONFIG_ARCH_HAS_CPU_IDLE_WAIT=y
@@ -26,7 +26,6 @@  CONFIG_AVERAGE=y
 # CONFIG_BACKLIGHT_ADP8870 is not set
 # CONFIG_BACKLIGHT_CLASS_DEVICE is not set
 CONFIG_BACKLIGHT_LCD_SUPPORT=y
-# CONFIG_BCM2708_DT is not set
 CONFIG_BCM2708_GPIO=y
 # CONFIG_BCM2708_NOL2CACHE is not set
 CONFIG_BCM2708_VCHIQ=y
@@ -258,6 +257,8 @@  CONFIG_USB_UAS=y
 CONFIG_USB_USBNET=y
 CONFIG_VECTORS_BASE=0xffff0000
 CONFIG_VFP=y
+# CONFIG_VMSPLIT_2G is not set
+# CONFIG_VMSPLIT_3G is not set
 CONFIG_VT=y
 CONFIG_VT_CONSOLE=y
 CONFIG_VT_CONSOLE_SLEEP=y
diff --git a/target/linux/brcm2708/profiles/100-RaspberryPi.mk b/target/linux/brcm2708/profiles/100-RaspberryPi.mk
deleted file mode 100644
index 8d10203..0000000
--- a/target/linux/brcm2708/profiles/100-RaspberryPi.mk
+++ /dev/null
@@ -1,17 +0,0 @@ 
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RaspberryPi
-  NAME:=RaspberryPi
-endef
-
-define Profile/RaspberryPi/Description
-	RaspberryPi board
-endef
-
-$(eval $(call Profile,RaspberryPi))
-