diff mbox

[OpenWrt-Devel,v3,4/4] base-files: taint the build if the override mechanism is used

Message ID 1422933629-25793-4-git-send-email-mathieu@qca.qualcomm.com
State Accepted
Headers show

Commit Message

Mathieu Olivari Feb. 3, 2015, 3:20 a.m. UTC
If some packages are overridden (using ./scripts/feeds -f), add a new
taint flag in /etc/openwrt_release. We'll use the CONFIG_OVERRIDE_PKGS
variable reported through the .config to detect it.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
---
 include/version.mk | 1 +
 1 file changed, 1 insertion(+)
diff mbox

Patch

diff --git a/include/version.mk b/include/version.mk
index c3cc170..99af96e 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -58,6 +58,7 @@  VERSION_TAINT_SPECS := \
 	+USE_EGLIBC:eglibc \
 	+USE_MKLIBS:mklibs \
 	+BUSYBOX_CUSTOM:busybox \
+	+OVERRIDE_PKGS:override \
 
 VERSION_TAINTS := $(strip $(foreach taint,$(VERSION_TAINT_SPECS), \
 	$(if $(findstring +,$(taint)), \