diff mbox

[OpenWrt-Devel,2/2] wpj558: use own partition for rootfs

Message ID 1422640100-25673-2-git-send-email-christian@m3hlis.de
State Rejected
Headers show

Commit Message

Christian Mehlis Jan. 30, 2015, 5:48 p.m. UTC
this change breaks rootfs detection

Signed-off-by: Christian Mehlis <christian@m3hlis.de>
---
 target/linux/ar71xx/image/Makefile | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Comments

John Crispin Feb. 2, 2015, 8:52 a.m. UTC | #1
On 30/01/2015 18:48, Christian Mehlis wrote:
> this change breaks rootfs detection
> 

so we should not merge it if it breaks stuff ?

> Signed-off-by: Christian Mehlis <christian@m3hlis.de>
> ---
>  target/linux/ar71xx/image/Makefile | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
> index ecaa126..9956a01 100644
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -690,10 +690,7 @@ define Image/Build/MyLoader
>  	$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
>  	if [ -e "$(fwimage)" ]; then \
>  		$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
> -			-p0x680000:0x160000:al:0x80060000:firmware:$(KDIR_TMP)/vmlinux-$(2).uImage \
> -			-p0x050000:0x630000:::rootfs:$(KDIR)/root.$(1) \
> -			-p0x7e0000:0x010000 \
> -			-p0x7f0000:0x010000 \
> +			-p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
>  			$(call imgname,$(1),$(2))-$(5)-factory.img; \
>  		echo -n "" > $(KDIR_TMP)/empty.bin; \
>  		sh $(TOPDIR)/scripts/combined-image.sh \
>
Christian Mehlis Feb. 2, 2015, 9:23 a.m. UTC | #2
Am 02.02.2015 um 09:52 schrieb John Crispin:
>
>
> On 30/01/2015 18:48, Christian Mehlis wrote:
>> this change breaks rootfs detection
>>
>
> so we should not merge it if it breaks stuff ?

Hi John,

this patch was the second way I tried to make the compex wpj558 work.
Perhaps you can answer my mail:

	[OpenWrt-Devel] Compex WPJ558 board support

This port is my first one, so I got some problems with the compex style 
uboot loader. I think jow did the port for at least two other compex 
boards, so I hope someone knows how to accomplish either way 1 or 2.

Best
Christian
diff mbox

Patch

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ecaa126..9956a01 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -690,10 +690,7 @@  define Image/Build/MyLoader
 	$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
 	if [ -e "$(fwimage)" ]; then \
 		$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
-			-p0x680000:0x160000:al:0x80060000:firmware:$(KDIR_TMP)/vmlinux-$(2).uImage \
-			-p0x050000:0x630000:::rootfs:$(KDIR)/root.$(1) \
-			-p0x7e0000:0x010000 \
-			-p0x7f0000:0x010000 \
+			-p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
 			$(call imgname,$(1),$(2))-$(5)-factory.img; \
 		echo -n "" > $(KDIR_TMP)/empty.bin; \
 		sh $(TOPDIR)/scripts/combined-image.sh \