diff mbox

[OpenWrt-Devel,v4,2/4] kernel.mk: Handle the x86_64 LINUX_KARCH case

Message ID 1418400142-6918-3-git-send-email-maxime.ripard@free-electrons.com
State Accepted
Headers show

Commit Message

Maxime Ripard Dec. 12, 2014, 4:02 p.m. UTC
x64 is handled by the x86 architecture in Linux, add a case for it in
LINUX_KARCH.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
---
 include/kernel.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Felix Fietkau Dec. 12, 2014, 6:30 p.m. UTC | #1
On 2014-12-12 17:02, Maxime Ripard wrote:
> x64 is handled by the x86 architecture in Linux, add a case for it in
> LINUX_KARCH.
> 
> Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Applied the first two patches in this series.

- Felix
diff mbox

Patch

diff --git a/include/kernel.mk b/include/kernel.mk
index b905cb9e1936..eeb0c3d2bd8e 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -72,7 +72,7 @@  else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
   LINUX_KARCH := mips
 else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
   LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386))
+else ifneq (,$(findstring $(ARCH), i386 x86_64))
   LINUX_KARCH := x86
 else
   LINUX_KARCH := $(ARCH)