diff mbox series

[OpenWrt-Devel] Add generic actions to sched-core

Message ID 0350dbbc-f50c-2d14-3311-9a713c2d6581@navigue.com
State Changes Requested
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] Add generic actions to sched-core | expand

Commit Message

Jonathan Thibault Nov. 16, 2018, 3:38 p.m. UTC
Greetings,

Next in my series of 'OpenWRT as a network swiss army knife' patches, I 
suggest having the ability to accept/drop frames with TC as part of 
sched-core.  This can be useful in cases where you need very fast (if 
simplistic) packet filtering.  I believe they are basic enough to be 
considered 'core' functionality.

Alternatively they could be packaged in kmod-sched since they aren't 
used oftené. At 9304 bytes (on octeon), I'm not sure it makes much of a 
difference.

act_skbedit
  SCHED_MODULES_FILTER = $(SCHED_MODULES_CORE) act_connmark sch_netem
  SCHED_MODULES_EXTRA = $(filter-out 
$(SCHED_MODULES_FILTER),$(SCHED_MODULES))
  SCHED_FILES = $(patsubst %,$(LINUX_DIR)/net/sched/%.ko,$(filter 
$(SCHED_MODULES_CORE),$(SCHED_MODULES)))
@@ -739,6 +739,7 @@ define KernelPackage/sched-core
         CONFIG_NET_CLS_ROUTE4 \
         CONFIG_NET_CLS_TCINDEX \
         CONFIG_NET_CLS_U32 \
+       CONFIG_NET_ACT_GACT \
         CONFIG_NET_ACT_MIRRED \
         CONFIG_NET_ACT_SKBEDIT \
         CONFIG_NET_EMATCH=y \

Comments

Hauke Mehrtens Nov. 24, 2018, 1:23 p.m. UTC | #1
On 11/16/18 4:38 PM, Jonathan Thibault wrote:
> Greetings,
> 
> Next in my series of 'OpenWRT as a network swiss army knife' patches, I
> suggest having the ability to accept/drop frames with TC as part of
> sched-core.  This can be useful in cases where you need very fast (if
> simplistic) packet filtering.  I believe they are basic enough to be
> considered 'core' functionality.
> 
> Alternatively they could be packaged in kmod-sched since they aren't
> used oftené. At 9304 bytes (on octeon), I'm not sure it makes much of a
> difference.
> 
> diff --git a/package/kernel/linux/modules/netsupport.mk
> b/package/kernel/linux/modules/netsupport.mk
> index f94c20d861..d822a93f1b 100644
> --- a/package/kernel/linux/modules/netsupport.mk
> +++ b/package/kernel/linux/modules/netsupport.mk
> @@ -716,7 +716,7 @@ $(eval $(call KernelPackage,mppe))
> 
> 
>  SCHED_MODULES = $(patsubst $(LINUX_DIR)/net/sched/%.ko,%,$(wildcard
> $(LINUX_DIR)/net/sched/*.ko))
> -SCHED_MODULES_CORE = sch_ingress sch_fq_codel sch_hfsc sch_htb sch_tbf
> cls_fw cls_route cls_flow cls_tcindex cls_u32 em_u32 act_mirred act_skbedit
> +SCHED_MODULES_CORE = sch_ingress sch_fq_codel sch_hfsc sch_htb sch_tbf
> cls_fw cls_route cls_flow cls_tcindex cls_u32 em_u32 act_gact act_mirred
> act_skbedit
>  SCHED_MODULES_FILTER = $(SCHED_MODULES_CORE) act_connmark sch_netem
>  SCHED_MODULES_EXTRA = $(filter-out
> $(SCHED_MODULES_FILTER),$(SCHED_MODULES))
>  SCHED_FILES = $(patsubst %,$(LINUX_DIR)/net/sched/%.ko,$(filter
> $(SCHED_MODULES_CORE),$(SCHED_MODULES)))
> @@ -739,6 +739,7 @@ define KernelPackage/sched-core
>         CONFIG_NET_CLS_ROUTE4 \
>         CONFIG_NET_CLS_TCINDEX \
>         CONFIG_NET_CLS_U32 \
> +       CONFIG_NET_ACT_GACT \
>         CONFIG_NET_ACT_MIRRED \
>         CONFIG_NET_ACT_SKBEDIT \
>         CONFIG_NET_EMATCH=y \

Hi,

This mail got whitespace damaged and is probably formated as HTML mail.
The patch in patchwork is also broken:
https://patchwork.ozlabs.org/patch/999009/

I would suggest to use git send-mail for sending patches.

Hauke
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/netsupport.mk 
b/package/kernel/linux/modules/netsupport.mk
index f94c20d861..d822a93f1b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -716,7 +716,7 @@  $(eval $(call KernelPackage,mppe))


  SCHED_MODULES = $(patsubst $(LINUX_DIR)/net/sched/%.ko,%,$(wildcard 
$(LINUX_DIR)/net/sched/*.ko))
-SCHED_MODULES_CORE = sch_ingress sch_fq_codel sch_hfsc sch_htb sch_tbf 
cls_fw cls_route cls_flow cls_tcindex cls_u32 em_u32 act_mirred act_skbedit
+SCHED_MODULES_CORE = sch_ingress sch_fq_codel sch_hfsc sch_htb sch_tbf 
cls_fw cls_route cls_flow cls_tcindex cls_u32 em_u32 act_gact act_mirred