mbox series

[ovs-dev,0/7] dp-packet: Refactor offload related names

Message ID 20220603151542.897026-1-mkp@redhat.com
Headers show
Series dp-packet: Refactor offload related names | expand

Message

Mike Pattrick June 3, 2022, 3:15 p.m. UTC
This patch refactors several function, variable, and definition names
for consistency and brevity.

cksum is changed to csum, p is the default name for a dp_packet, b is
the default name for a dp_packet_batch, ol instead of hwol, and some
checksum offload related functions are renamed to indicate direction.

Flavio Leitner (7):
  Rename flags with CKSUM to CSUM.
  Prefix netdev offload flags with NETDEV_OFFLOAD_.
  Rename dp_packet_hwol to dp_packet_ol.
  dp-packet: Use p for packet and b for batch.
  dp-packet: Rename dp_packet_ol_tcp_seg
  dp-packet: Rename dp_packet_ol l4 functions.
  dp-packet: Add _ol_ to functions using OL flags.

 lib/conntrack.c           |  16 +-
 lib/dp-packet.c           | 336 +++++++++++-----------
 lib/dp-packet.h           | 580 +++++++++++++++++++-------------------
 lib/ipf.c                 |  10 +-
 lib/netdev-dpdk.c         |  40 +--
 lib/netdev-dummy.c        |   8 +-
 lib/netdev-linux.c        |  64 ++---
 lib/netdev-native-tnl.c   |   4 +-
 lib/netdev-offload-dpdk.c |   2 +-
 lib/netdev-provider.h     |  10 +-
 lib/netdev.c              |  32 +--
 lib/packets.c             |   2 +-
 12 files changed, 551 insertions(+), 553 deletions(-)