mbox series

[ovs-dev,00/10] Use DP_PACKET_BATCH_FOR_EACH macro.

Message ID 1505849344-52387-1-git-send-email-bhanuprakash.bodireddy@intel.com
Headers show
Series Use DP_PACKET_BATCH_FOR_EACH macro. | expand

Message

Bodireddy, Bhanuprakash Sept. 19, 2017, 7:28 p.m. UTC
DP_PACKET_BATCH_FOR_EACH macro was introduced early this year as part
of enhancing packet batch APIs. Commit '72c84bc2' implemented this macro
and replaced most of the calling sites with macros and simplified the logic.

However there are still many APIs that needs to be fixed.
This patch series is a simple and straightforward set of changes
aimed at using DP_PACKET_BATCH_FOR_EACH macro at all appropriate places.
Also minor code cleanup is done to improve readability of the code.

No functionality changes and no performance impact with this series.

Bhanuprakash Bodireddy (10):
  netdev-linux: Clean up netdev_linux_sock_batch_send().
  netdev-linux: Use DP_PACKET_BATCH_FOR_EACH in
    netdev_linux_tap_batch_send.
  netdev-dpdk: Cleanup dpdk_do_tx_copy.
  netdev-dpdk: Minor cleanup of netdev_dpdk_send__.
  netdev-dpdk: Use DP_PACKET_BATCH_FOR_EACH in netdev_dpdk_ring_send
  netdev-bsd: Use DP_PACKET_BATCH_FOR_EACH in netdev_bsd_send.
  odp-execute: Use const qualifer for batch size.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in dp_netdev_run_meter.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in fast_path_processing.
  dpif-netdev: Remove 'cnt' in dp_netdev_input__().

 lib/dpif-netdev.c  | 33 +++++++++++++++------------------
 lib/netdev-bsd.c   |  7 ++++---
 lib/netdev-dpdk.c  | 40 +++++++++++++++++++---------------------
 lib/netdev-linux.c | 17 +++++++++--------
 lib/odp-execute.c  |  3 ++-
 5 files changed, 49 insertions(+), 51 deletions(-)

Comments

Darrell Ball Sept. 19, 2017, 9:38 p.m. UTC | #1
Hi Bhanu

You have many instances where you want to use DP_PACKET_BATCH_FOR_EACH
You have another series partially about this:
https://patchwork.ozlabs.org/patch/813007/

Also, this series mixes in other changes like creating new variables for clarity, I guess,
and removing unneeded variables. which anyways has different motivation but part of the same patch.

Do you think it makes sense to group the DP_PACKET_BATCH_FOR_EACH changes in 
one patch and splice out the other changes as other patches in the same series by same theme ?

Thanks 
Darrell

On 9/19/17, 12:39 PM, "ovs-dev-bounces@openvswitch.org on behalf of Bhanuprakash Bodireddy" <ovs-dev-bounces@openvswitch.org on behalf of bhanuprakash.bodireddy@intel.com> wrote:

    DP_PACKET_BATCH_FOR_EACH macro was introduced early this year as part
    of enhancing packet batch APIs. Commit '72c84bc2' implemented this macro
    and replaced most of the calling sites with macros and simplified the logic.
    
    However there are still many APIs that needs to be fixed.
    This patch series is a simple and straightforward set of changes
    aimed at using DP_PACKET_BATCH_FOR_EACH macro at all appropriate places.
    Also minor code cleanup is done to improve readability of the code.
    
    No functionality changes and no performance impact with this series.
    
    Bhanuprakash Bodireddy (10):
      netdev-linux: Clean up netdev_linux_sock_batch_send().
      netdev-linux: Use DP_PACKET_BATCH_FOR_EACH in
        netdev_linux_tap_batch_send.
      netdev-dpdk: Cleanup dpdk_do_tx_copy.
      netdev-dpdk: Minor cleanup of netdev_dpdk_send__.
      netdev-dpdk: Use DP_PACKET_BATCH_FOR_EACH in netdev_dpdk_ring_send
      netdev-bsd: Use DP_PACKET_BATCH_FOR_EACH in netdev_bsd_send.
      odp-execute: Use const qualifer for batch size.
      dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in dp_netdev_run_meter.
      dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in fast_path_processing.
      dpif-netdev: Remove 'cnt' in dp_netdev_input__().
    
     lib/dpif-netdev.c  | 33 +++++++++++++++------------------
     lib/netdev-bsd.c   |  7 ++++---
     lib/netdev-dpdk.c  | 40 +++++++++++++++++++---------------------
     lib/netdev-linux.c | 17 +++++++++--------
     lib/odp-execute.c  |  3 ++-
     5 files changed, 49 insertions(+), 51 deletions(-)
    
    -- 
    2.4.11
    _______________________________________________
    dev mailing list
    dev@openvswitch.org
    https://urldefense.proofpoint.com/v2/url?u=https-3A__mail.openvswitch.org_mailman_listinfo_ovs-2Ddev&d=DwICAg&c=uilaK90D4TOVoH58JNXRgQ&r=BVhFA09CGX7JQ5Ih-uZnsw&m=XiubftJP8lYJL_SPaytZ9IvK97Hxqfr-TwV3fcbd2Qw&s=NzGP8ioHmW7p2aaJepNTw7ayyFxEmuPXEnYpmoN7yOU&e=
Bodireddy, Bhanuprakash Sept. 20, 2017, 1:31 p.m. UTC | #2
Hi Darrell,

>You have many instances where you want to use
>DP_PACKET_BATCH_FOR_EACH You have another series partially about this:
>https://patchwork.ozlabs.org/patch/813007/
>
>Also, this series mixes in other changes like creating new variables for clarity, I
>guess, and removing unneeded variables. which anyways has different
>motivation but part of the same patch.
>
>Do you think it makes sense to group the DP_PACKET_BATCH_FOR_EACH
>changes in one patch and splice out the other changes as other patches in the
>same series by same theme ?

That makes sense and I sent out a v2 by merging the 2 patches of my previous series. 
This time the patches are grouped and I added the details in the cover letter under version info.

Cover letter:  https://mail.openvswitch.org/pipermail/ovs-dev/2017-September/338990.html
https://patchwork.ozlabs.org/patch/816191/

- Bhanuprakash.

>
>Thanks
>Darrell
>
>On 9/19/17, 12:39 PM, "ovs-dev-bounces@openvswitch.org on behalf of
>Bhanuprakash Bodireddy" <ovs-dev-bounces@openvswitch.org on behalf of
>bhanuprakash.bodireddy@intel.com> wrote:
>
>    DP_PACKET_BATCH_FOR_EACH macro was introduced early this year as
>part
>    of enhancing packet batch APIs. Commit '72c84bc2' implemented this macro
>    and replaced most of the calling sites with macros and simplified the logic.
>
>    However there are still many APIs that needs to be fixed.
>    This patch series is a simple and straightforward set of changes
>    aimed at using DP_PACKET_BATCH_FOR_EACH macro at all appropriate
>places.
>    Also minor code cleanup is done to improve readability of the code.
>
>    No functionality changes and no performance impact with this series.
>
>    Bhanuprakash Bodireddy (10):
>      netdev-linux: Clean up netdev_linux_sock_batch_send().
>      netdev-linux: Use DP_PACKET_BATCH_FOR_EACH in
>        netdev_linux_tap_batch_send.
>      netdev-dpdk: Cleanup dpdk_do_tx_copy.
>      netdev-dpdk: Minor cleanup of netdev_dpdk_send__.
>      netdev-dpdk: Use DP_PACKET_BATCH_FOR_EACH in
>netdev_dpdk_ring_send
>      netdev-bsd: Use DP_PACKET_BATCH_FOR_EACH in netdev_bsd_send.
>      odp-execute: Use const qualifer for batch size.
>      dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in
>dp_netdev_run_meter.
>      dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in fast_path_processing.
>      dpif-netdev: Remove 'cnt' in dp_netdev_input__().
>
>     lib/dpif-netdev.c  | 33 +++++++++++++++------------------
>     lib/netdev-bsd.c   |  7 ++++---
>     lib/netdev-dpdk.c  | 40 +++++++++++++++++++---------------------
>     lib/netdev-linux.c | 17 +++++++++--------
>     lib/odp-execute.c  |  3 ++-
>     5 files changed, 49 insertions(+), 51 deletions(-)
>
>    --
>    2.4.11
>    _______________________________________________
>    dev mailing list
>    dev@openvswitch.org
>    https://urldefense.proofpoint.com/v2/url?u=https-
>3A__mail.openvswitch.org_mailman_listinfo_ovs-
>2Ddev&d=DwICAg&c=uilaK90D4TOVoH58JNXRgQ&r=BVhFA09CGX7JQ5Ih-
>uZnsw&m=XiubftJP8lYJL_SPaytZ9IvK97Hxqfr-
>TwV3fcbd2Qw&s=NzGP8ioHmW7p2aaJepNTw7ayyFxEmuPXEnYpmoN7yOU&
>e=
>