Message ID | 1363111675-21457-1-git-send-email-silviupopescu1990@gmail.com |
---|---|
State | Accepted |
Headers | show |
On Tue, Mar 12, 2013 at 08:07:55PM +0200, Silviu-Mihai Popescu wrote: > This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase > readability. Applied, thanks. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/net/ipv4/netfilter/arptable_filter.c b/net/ipv4/netfilter/arptable_filter.c index 79ca5e7..eadab1e 100644 --- a/net/ipv4/netfilter/arptable_filter.c +++ b/net/ipv4/netfilter/arptable_filter.c @@ -48,9 +48,7 @@ static int __net_init arptable_filter_net_init(struct net *net) net->ipv4.arptable_filter = arpt_register_table(net, &packet_filter, repl); kfree(repl); - if (IS_ERR(net->ipv4.arptable_filter)) - return PTR_ERR(net->ipv4.arptable_filter); - return 0; + return PTR_RET(net->ipv4.arptable_filter); } static void __net_exit arptable_filter_net_exit(struct net *net)
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu <silviupopescu1990@gmail.com> --- net/ipv4/netfilter/arptable_filter.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)