diff mbox series

[V3,net-next,3/6] net: ena: ethtool: get_channels: use combined only

Message ID 20191006123328.24210-4-sameehj@amazon.com
State Accepted
Delegated to: David Miller
Headers show
Series [V3,net-next,1/6] net: ena: change num_queues to num_io_queues for clarity and consistency | expand

Commit Message

Jubran, Samih Oct. 6, 2019, 12:33 p.m. UTC
From: Sameeh Jubran <sameehj@amazon.com>

Since we use the same IRQ and NAPI to service RX and TX then we need to
use a combined channel instead of rx and tx channels.

Signed-off-by: Sameeh Jubran <sameehj@amazon.com>
---
 drivers/net/ethernet/amazon/ena/ena_ethtool.c | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/drivers/net/ethernet/amazon/ena/ena_ethtool.c b/drivers/net/ethernet/amazon/ena/ena_ethtool.c
index 3ad661fd9..03b4ae7ba 100644
--- a/drivers/net/ethernet/amazon/ena/ena_ethtool.c
+++ b/drivers/net/ethernet/amazon/ena/ena_ethtool.c
@@ -734,14 +734,8 @@  static void ena_get_channels(struct net_device *netdev,
 {
 	struct ena_adapter *adapter = netdev_priv(netdev);
 
-	channels->max_rx = adapter->num_io_queues;
-	channels->max_tx = adapter->num_io_queues;
-	channels->max_other = 0;
-	channels->max_combined = 0;
-	channels->rx_count = adapter->num_io_queues;
-	channels->tx_count = adapter->num_io_queues;
-	channels->other_count = 0;
-	channels->combined_count = 0;
+	channels->max_combined = adapter->num_io_queues;
+	channels->combined_count = adapter->num_io_queues;
 }
 
 static int ena_get_tunable(struct net_device *netdev,