diff mbox

tc: respect LDFLAGS for %.so targets

Message ID 1261857156-9037-1-git-send-email-vapier@gentoo.org
State Accepted, archived
Delegated to: stephen hemminger
Headers show

Commit Message

Mike Frysinger Dec. 26, 2009, 7:52 p.m. UTC
Since there aren't any targets that currently use this pattern rule, this
is more of a proactive fix.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 tc/Makefile |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

stephen hemminger Jan. 21, 2010, 6:05 p.m. UTC | #1
On Sat, 26 Dec 2009 14:52:36 -0500
Mike Frysinger <vapier@gentoo.org> wrote:

> Since there aren't any targets that currently use this pattern rule, this
> is more of a proactive fix.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
>  tc/Makefile |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/tc/Makefile b/tc/Makefile
> index f3dd2b7..0b5d7d3 100644
> --- a/tc/Makefile
> +++ b/tc/Makefile
> @@ -87,7 +87,7 @@ YACC := bison
>  LEX := flex
>  
>  %.so: %.c
> -	$(CC) $(CFLAGS) -shared -fpic $< -o $@
> +	$(CC) $(CFLAGS) $(LDFLAGS) -shared -fpic $< -o $@
>  
>  
>  all: libtc.a tc $(TCSO)

applied
diff mbox

Patch

diff --git a/tc/Makefile b/tc/Makefile
index f3dd2b7..0b5d7d3 100644
--- a/tc/Makefile
+++ b/tc/Makefile
@@ -87,7 +87,7 @@  YACC := bison
 LEX := flex
 
 %.so: %.c
-	$(CC) $(CFLAGS) -shared -fpic $< -o $@
+	$(CC) $(CFLAGS) $(LDFLAGS) -shared -fpic $< -o $@
 
 
 all: libtc.a tc $(TCSO)