mbox series

[net-next,v5,0/9] XDP Redirect implementation for ENA driver

Message ID 20201208180208.26111-1-shayagr@amazon.com
Headers show
Series XDP Redirect implementation for ENA driver | expand

Message

Shay Agroskin Dec. 8, 2020, 6:01 p.m. UTC
Hi all,
ENA is adding XDP Redirect support for its driver and some other
small tweaks.

This series adds the following:

- Make log messages in the driver have a uniform format using
  netdev_* function
- Improve code readability
- Add support for XDP Redirect

v1->v2: Removed the word "atomic" from the name of
	ena_increase_stat_atomic() as it is misleading.

v2->v3: Fixed checkpatch errors

v3->v4: Added an explanation to the decision of using netdev_* prints in
	functions that are also called before netdev is registered.

v4->v5: Added return value check for xdp_do_redirect() and
	xdp_convert_buff_to_frame(). Also replace the variable casting
	in patch 3 with something more readable.

Shay Agroskin (9):
  net: ena: use constant value for net_device allocation
  net: ena: add device distinct log prefix to files
  net: ena: store values in their appropriate variables types
  net: ena: fix coding style nits
  net: ena: aggregate stats increase into a function
  net: ena: use xdp_frame in XDP TX flow
  net: ena: introduce XDP redirect implementation
  net: ena: use xdp_return_frame() to free xdp frames
  net: ena: introduce ndo_xdp_xmit() function for XDP_REDIRECT

 drivers/net/ethernet/amazon/ena/ena_com.c     | 391 ++++++++++-------
 drivers/net/ethernet/amazon/ena/ena_com.h     |  23 +-
 drivers/net/ethernet/amazon/ena/ena_eth_com.c |  71 +--
 drivers/net/ethernet/amazon/ena/ena_eth_com.h |  23 +-
 drivers/net/ethernet/amazon/ena/ena_ethtool.c |   3 +-
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 403 ++++++++++--------
 drivers/net/ethernet/amazon/ena/ena_netdev.h  |  12 +-
 7 files changed, 551 insertions(+), 375 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Dec. 9, 2020, 11:50 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (refs/heads/master):

On Tue, 8 Dec 2020 20:01:59 +0200 you wrote:
> Hi all,
> ENA is adding XDP Redirect support for its driver and some other
> small tweaks.
> 
> This series adds the following:
> 
> - Make log messages in the driver have a uniform format using
>   netdev_* function
> - Improve code readability
> - Add support for XDP Redirect
> 
> [...]

Here is the summary with links:
  - [net-next,v5,1/9] net: ena: use constant value for net_device allocation
    https://git.kernel.org/netdev/net-next/c/ce74496a1575
  - [net-next,v5,2/9] net: ena: add device distinct log prefix to files
    https://git.kernel.org/netdev/net-next/c/da580ca8de2c
  - [net-next,v5,3/9] net: ena: store values in their appropriate variables types
    https://git.kernel.org/netdev/net-next/c/e9548fdf93bc
  - [net-next,v5,4/9] net: ena: fix coding style nits
    https://git.kernel.org/netdev/net-next/c/1e5847395eeb
  - [net-next,v5,5/9] net: ena: aggregate stats increase into a function
    https://git.kernel.org/netdev/net-next/c/89dd735e8c1e
  - [net-next,v5,6/9] net: ena: use xdp_frame in XDP TX flow
    https://git.kernel.org/netdev/net-next/c/e8223eeff021
  - [net-next,v5,7/9] net: ena: introduce XDP redirect implementation
    https://git.kernel.org/netdev/net-next/c/a318c70ad152
  - [net-next,v5,8/9] net: ena: use xdp_return_frame() to free xdp frames
    https://git.kernel.org/netdev/net-next/c/f8b91f255a05
  - [net-next,v5,9/9] net: ena: introduce ndo_xdp_xmit() function for XDP_REDIRECT
    https://git.kernel.org/netdev/net-next/c/f1a255891303

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html