mbox series

[mlx5-next,00/16] mlx5 next updates 2020-11-20

Message ID 20201120230339.651609-1-saeedm@nvidia.com
Headers show
Series mlx5 next updates 2020-11-20 | expand

Message

Saeed Mahameed Nov. 20, 2020, 11:03 p.m. UTC
Hi,

This series includes trivial updates to mlx5 next branch
1) HW definition for upcoming features
2) Include files and general Cleanups
3) Add the upcoming BlueField-3 device ID
4) Define flow steering priority for VDPA
5) Export missing steering API for ULPs,
   will be used later in VDPA driver, to create flow steering domain for
   VDPA queues.
6) ECPF (Embedded CPU Physical function) minor improvements for BlueField.

In case of no objection this series will be applied to mlx5-next, and sent
as a pull request to both net-next and rdma-next trees.

Thanks,
Saeed.

---

Aya Levin (1):
  net/mlx5: Expose IP-in-IP TX and RX capability bits

Chris Mi (2):
  net/mlx5: Add sample offload hardware bits and structures
  net/mlx5: Add sampler destination type

Eli Cohen (2):
  net/mlx5: Add VDPA priority to NIC RX namespace
  net/mlx5: Export steering related functions

Eran Ben Elisha (1):
  net/mlx5: Add ts_cqe_to_dest_cqn related bits

Meir Lichtinger (1):
  net/mlx5: Update the list of the PCI supported devices

Muhammad Sammar (2):
  net/mlx5: Check dr mask size against mlx5_match_param size
  net/mlx5: Add misc4 to mlx5_ifc_fte_match_param_bits

Parav Pandit (6):
  net/mlx5: Avoid exposing driver internal command helpers
  net/mlx5: Update the hardware interface definition for vhca state
  net/mlx5: Make API mlx5_core_is_ecpf accept const pointer
  net/mlx5: Rename peer_pf to host_pf
  net/mlx5: Enable host PF HCA after eswitch is initialized
  net/mlx5: Treat host PF vport as other (non eswitch manager) vport

Yishai Hadas (1):
  net/mlx5: Expose other function ifc bits

 drivers/net/ethernet/mellanox/mlx5/core/cmd.c |  3 -
 .../mellanox/mlx5/core/diag/fs_tracepoint.c   |  3 +
 .../net/ethernet/mellanox/mlx5/core/ecpf.c    | 76 ++++++++++-----
 .../net/ethernet/mellanox/mlx5/core/ecpf.h    |  3 +
 .../mellanox/mlx5/core/esw/acl/helper.c       |  5 +-
 .../net/ethernet/mellanox/mlx5/core/eswitch.c | 29 +++++-
 .../net/ethernet/mellanox/mlx5/core/fs_cmd.c  | 57 ++++++-----
 .../net/ethernet/mellanox/mlx5/core/fs_core.c | 27 +++---
 .../net/ethernet/mellanox/mlx5/core/fs_core.h |  2 +-
 .../net/ethernet/mellanox/mlx5/core/main.c    | 19 ++--
 .../ethernet/mellanox/mlx5/core/mlx5_core.h   |  4 +
 .../ethernet/mellanox/mlx5/core/pagealloc.c   | 12 +--
 .../mellanox/mlx5/core/steering/dr_matcher.c  |  2 +-
 .../mellanox/mlx5/core/steering/dr_rule.c     |  3 +-
 .../mellanox/mlx5/core/steering/dr_types.h    |  1 +
 include/linux/mlx5/device.h                   |  8 ++
 include/linux/mlx5/driver.h                   |  8 +-
 include/linux/mlx5/fs.h                       |  7 +-
 include/linux/mlx5/mlx5_ifc.h                 | 94 +++++++++++++++++--
 include/uapi/rdma/mlx5_user_ioctl_cmds.h      |  2 +-
 20 files changed, 260 insertions(+), 105 deletions(-)

Comments

Saeed Mahameed Nov. 30, 2020, 6:42 p.m. UTC | #1
On Fri, 2020-11-20 at 15:03 -0800, Saeed Mahameed wrote:
> Hi,
> 
> This series includes trivial updates to mlx5 next branch
> 1) HW definition for upcoming features
> 2) Include files and general Cleanups
> 3) Add the upcoming BlueField-3 device ID
> 4) Define flow steering priority for VDPA
> 5) Export missing steering API for ULPs,
>    will be used later in VDPA driver, to create flow steering domain
> for
>    VDPA queues.
> 6) ECPF (Embedded CPU Physical function) minor improvements for
> BlueField.
> 

Series applied to mlx5-next without the VDPA patch.

Jakub, please let me know if you still have concerns regarding that
patch, i will eventually need to apply it, regardless of the outcome of
the RDMA vs ETH discussion, it is just how we configure the HW :).

Thanks,
Saeed.