mbox series

[bpf-next,0/3] rename *_info_cnt to nr_*_info in bpf_prog_info

Message ID 20181210221410.2983805-1-yhs@fb.com
Headers show
Series rename *_info_cnt to nr_*_info in bpf_prog_info | expand

Message

Yonghong Song Dec. 10, 2018, 10:14 p.m. UTC
Before func_info and line_info are added to the kernel, there are several
fields in structure bpf_prog_info specifying the "count" of a user buffer, e.g.,
        __u32 nr_jited_ksyms;
        __u32 nr_jited_func_lens;
The naming convention has the prefix "nr_".

The func_info and line_info support added several fields
        __u32 func_info_cnt;
        __u32 line_info_cnt;
        __u32 jited_line_info_cnt;
to indicate the "count" of buffers func_info, line_info and jited_line_info.
The original intention is to keep the field names the same as those in
structure bpf_attr, so it will be clear that the "count" returned to user
space will be the same as the one passed to the kernel during prog load.

Unfortunately, the field names *_info_cnt are not consistent with
other existing fields in bpf_prog_info.
This patch set renamed the fields *_info_cnt to nr_*_info
to keep naming convention consistent.

Yonghong Song (3):
  bpf: rename *_info_cnt to nr_*_info in bpf_prog_info
  tools/bpf: sync kernel uapi bpf.h to tools directory
  tools/bpf: rename *_info_cnt to nr_*_info

 include/uapi/linux/bpf.h               |  6 +--
 kernel/bpf/syscall.c                   | 38 ++++++++--------
 tools/bpf/bpftool/prog.c               | 48 ++++++++++-----------
 tools/include/uapi/linux/bpf.h         |  6 +--
 tools/lib/bpf/bpf_prog_linfo.c         |  4 +-
 tools/testing/selftests/bpf/test_btf.c | 60 +++++++++++++-------------
 6 files changed, 81 insertions(+), 81 deletions(-)

Comments

Alexei Starovoitov Dec. 10, 2018, 11:01 p.m. UTC | #1
On 12/10/18 2:14 PM, Yonghong Song wrote:
> Before func_info and line_info are added to the kernel, there are several
> fields in structure bpf_prog_info specifying the "count" of a user buffer, e.g.,
>          __u32 nr_jited_ksyms;
>          __u32 nr_jited_func_lens;
> The naming convention has the prefix "nr_".
> 
> The func_info and line_info support added several fields
>          __u32 func_info_cnt;
>          __u32 line_info_cnt;
>          __u32 jited_line_info_cnt;
> to indicate the "count" of buffers func_info, line_info and jited_line_info.
> The original intention is to keep the field names the same as those in
> structure bpf_attr, so it will be clear that the "count" returned to user
> space will be the same as the one passed to the kernel during prog load.
> 
> Unfortunately, the field names *_info_cnt are not consistent with
> other existing fields in bpf_prog_info.
> This patch set renamed the fields *_info_cnt to nr_*_info
> to keep naming convention consistent.

Applied to bpf-next. Thanks